The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Clamavconnector on freebsd

Discussion in 'cPanel Developers' started by Esky, Jun 12, 2006.

  1. Esky

    Esky Active Member

    Joined:
    Mar 15, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Netherlands
    cPanel Access Level:
    DataCenter Provider
    I'm running cpanel 10.8 on freebsd with the clamavconnector installed.

    In the /var/log/clam-update.log it says:

    So I checked but libgmp is installed so what is wrong here????
     
  2. Esky

    Esky Active Member

    Joined:
    Mar 15, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Netherlands
    cPanel Access Level:
    DataCenter Provider
  3. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Nothing wrong with clam on our FREEBSD. See if you can update it manually.

    Log in as root and type

    # freshclam

    Then see it it updates. That error suggest that the clamav database server is down or not reachable.

    You can also change the database server in the freshclam.conf file in the /etc directory.

    Change this line to access the US mirror server.
    From
    DatabaseMirror database.clamav.net
    To
    DatabaseMirror US.clamav.net

    Then run freshclam from root again.
     
    #3 easyhoster1, Aug 12, 2006
    Last edited: Aug 12, 2006
  4. Esky

    Esky Active Member

    Joined:
    Mar 15, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Netherlands
    cPanel Access Level:
    DataCenter Provider
    thanx for the advise, but just running freshclam as root does not solve the problem nor is the database server down. As you can see in the link I posted the only option I've found sofar is to run freshclam manually with the --user=root option and than changing permissions.
     

Share This Page