doiz

Member
Jan 11, 2004
12
0
151
I have clamavconnector installed and updated.

Name: clamavconnector
Author: cPanel Inc.
Installed Version: 0.87-1.0
Version: 0.87-1.0
However, I keep receiving the following warnings:

ClamAV update process started at Sat Oct 8 13:16:08 2005
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.86.2 Recommended version: 0.87
DON'T PANIC! Read http://www.clamav.net/faq.html
main.cvd is up to date (version: 34, sigs: 39625, f-level: 5, builder: tkojm)
daily.cvd is up to date (version: 1123, sigs: 882, f-level: 6, builder: arnaud)
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Current functionality level = 5, recommended = 6
DON'T PANIC! Read http://www.clamav.net/faq.html
ClamAV update process started at Sat Oct 8 13:16:39 2005
Reading CVD header (main.cvd): OK
main.cvd is up to date (version: 34, sigs: 39625, f-level: 5, builder: tkojm)
WARNING: Your ClamAV installation is OUTDATED - please update immediately !
WARNING: Current functionality level = 2, required = 5
Reading CVD header (daily.cvd): OK
daily.cvd is up to date (version: 1123, sigs: 882, f-level: 6, builder: arnaud)
WARNING: Your ClamAV installation is OUTDATED - please update immediately !
WARNING: Current functionality level = 2, required = 6
Please advise, Thanks.
 

doiz

Member
Jan 11, 2004
12
0
151
whereis freshclam and whereis clamscan shows two locations

/usr/lib
/usr/local/lib

How can I tell which one is running, and which one to remove?
 
Last edited:

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,466
31
473
Go on, have a guess
I'd suggest removing clamavconnector, run the following and the install the clamavconnector again:

Code:
killall clamd

/bin/rm -Rfv /usr/bin/clam*
/bin/rm -Rfv /usr/sbin/clam*
/bin/rm -Rfv /usr/lib/libclam*
/bin/rm -Rfv /usr/share/clam*
/bin/rm -Rfv /usr/include/clam*
/bin/rm -Rfv /usr/bin/freshclam*
/bin/rm -Rfv /usr/etc/clamav*

/bin/rm -Rfv /usr/local/bin/clam*
/bin/rm -Rfv /usr/local/sbin/clam*
/bin/rm -Rfv /usr/local/lib/libclam*
/bin/rm -Rfv /usr/local/share/clam*
/bin/rm -Rfv /usr/local/include/clam*
/bin/rm -Rfv /usr/local/bin/freshclam*
/bin/rm -Rfv /usr/local/etc/clamav*
 

marfa

Member
Jul 23, 2004
6
0
151
chirpy said:
I'd suggest removing clamavconnector, run the following and the install the clamavconnector again:

Code:
killall clamd

/bin/rm -Rfv /usr/bin/clam*
/bin/rm -Rfv /usr/sbin/clam*
/bin/rm -Rfv /usr/lib/libclam*
/bin/rm -Rfv /usr/share/clam*
/bin/rm -Rfv /usr/include/clam*
/bin/rm -Rfv /usr/bin/freshclam*
/bin/rm -Rfv /usr/etc/clamav*

/bin/rm -Rfv /usr/local/bin/clam*
/bin/rm -Rfv /usr/local/sbin/clam*
/bin/rm -Rfv /usr/local/lib/libclam*
/bin/rm -Rfv /usr/local/share/clam*
/bin/rm -Rfv /usr/local/include/clam*
/bin/rm -Rfv /usr/local/bin/freshclam*
/bin/rm -Rfv /usr/local/etc/clamav*
I was having the same problem as doiz so I used this thread and it worked, except that now I am getting the following:

WARNING: Your ClamAV installation is OUTDATED - please update immediately !: 1 Time(s)
WARNING: Current functionality level = 2, required = 3: 1 Time(s)