Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Clamconnector on 11.28.52 64-bit VPS: No binaries

Discussion in 'General Discussion' started by movielad, Dec 21, 2010.

  1. movielad

    movielad Well-Known Member

    Joined:
    May 14, 2003
    Messages:
    109
    Likes Received:
    2
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    I'm trying to figure out why ClamConnector on my 11.28.52 VPS appears to compile okay, but does not install any of the ClamAV binaries. If you look at:

    Code:
    root@host1 [~]# /usr/local/bin/freshclam
    -bash: /usr/local/bin/freshclam: No such file or directory
    root@host1 [~]# cd /usr/local/bin
    root@host1 [/usr/local/bin]# ls -al freshclam
    lrwxrwxrwx 1 root root 19 Dec  8 13:19 freshclam -> ../../bin/freshclam
    root@host1 [/usr/local/bin]# /scripts/restartsrv_clamd
    Unable to locate clamd
    
    Short of installing ClamAV manually and then re-running ClamConnector manually, I'm not quite sure what else do to. The VPS is Xen based running 64-bit CentOS 5.5.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelJared

    cPanelJared Technical Analyst

    Joined:
    Feb 25, 2010
    Messages:
    1,835
    Likes Received:
    21
    Trophy Points:
    143
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    What is the value of Max cPanel process memory in Main >> Server Configuration >> Tweak Settings? Try increasing it, or setting it to Unlimited, and then uninstalling and reinstalling clamavconnector using Main >> cPanel >> Manage Plugins.

    If this does not help, please submit a ticket so that we can investigate this directly on your server, because ClamAV should be fully installing when you install it from the WebHost Manager interface.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. movielad

    movielad Well-Known Member

    Joined:
    May 14, 2003
    Messages:
    109
    Likes Received:
    2
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    Twitter:
    That did the trick. I disabled limitations for the cPanel process memory, uninstalled and re-installed ClamAVConnector and it installed just fine. Binaries all in place and Clamd running.

    Many thanks!

    Martyn
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...
Similar Threads - Clamconnector binaries
  1. jndawson
    Replies:
    22
    Views:
    2,050

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice