Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

clamd continuously failing

Discussion in 'General Discussion' started by electron33, Apr 28, 2008.

  1. electron33

    electron33 Well-Known Member

    Joined:
    Feb 24, 2004
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    166
    After my last cPanel upgrade to WHM 11.15.0 cPanel 11.18.3-R21703, clamd keeps failing.

    I've tried

    /script/upcp --force

    but, no luck.

    Any ideas?
    Thanks
     
  2. electron33

    electron33 Well-Known Member

    Joined:
    Feb 24, 2004
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    166
    I tried to run clamd

    /usr/sbin/clamd

    and it complained about non-parsable file /etc/clamd.conf with the following:

    ERROR: Parse error at line 244: Unknown option ArchiveMaxFileSize.
    ERROR: Can't open/parse the config file /etc/clamd.conf

    ERROR: Parse error at line 251: Unknown option ArchiveMaxRecursion.
    ERROR: Can't open/parse the config file /etc/clamd.conf


    ERROR: Parse error at line 256: Unknown option ArchiveMaxFiles.
    ERROR: Can't open/parse the config file /etc/clamd.conf


    After I edited /etc/clamd.conf and commented out the above directive, clamd started.

    I still don't know what's going on, although clamd is now stable.

    Any help is appreciated.
     
  3. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,342
    Likes Received:
    58
    Trophy Points:
    178
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    > clamd:
    > - NEW CONFIG FILE OPTIONS: MaxScanSize, MaxFileSize, MaxRecursion,
    > MaxFiles
    > - ** THE FOLLOWING OPTIONS ARE NO LONGER SUPPORTED **:
    > MailMaxRecursion,
    > ArchiveMaxFileSize, ArchiveMaxRecursion, ArchiveMaxFiles,
    > ArchiveMaxCompressionRatio, ArchiveBlockMax

    So the answer is to update your /etc/clamd.conf file with the appropriate new option which replaces the old option.

    Mike
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice