The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Clamd crapping out

Discussion in 'E-mail Discussions' started by beddo, Feb 14, 2008.

  1. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    This has now happened twice to me. Clamd stops responding completely but there are not logs at all about it. All I get in exim's mainlog is:

    2008-02-14 00:58:30 *** malware acl condition: clamd: unable to connect to UNIX socket /var/clamd (Connection refused)

    I'm running:

    WHM 11.15.0 cPanel 11.18.0-C20595
    FREEBSD 6.2-RELEASE amd64 on standard - WHM X v3.1.0

    For some reason there no longer seems to be any files in /usr/local/etc/rc.d for starting/stopping clamd, freshclam etc like I used to have. There is nothing in WHM either and restarting exim does nothing.

    To fix it, I have to go Cpanel -> Manage plugins -> uninstall then reinstall.

    I would like to know a couple of things:

    1) How to make it so that exim doesn't reject all its mail when clamd goes down.
    2) Where the logs and controls for clamd are seen as they don't seem to be in the normal place
     
  2. Bruce

    Bruce Well-Known Member

    Joined:
    Oct 4, 2001
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    I'm having the same problem after Upgrade to WHM 11.15.0 cPanel 11.18.1-S20683

    If I un-install and re-install, it craps out ten minutes later.
    Had to uninstall and leave it that way, because some clients e-mails were timing out when trying to send..
     
  3. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    Anyone...anything?
     
  4. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    I third this problem
     
  5. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    You can restart clam with:

    /scripts/restartsrv_clamd

    It should also be restarted when you restart exim using any of the below commands:

    /scripts/restartsrv_exim
    service exim restart
    /etc/rc.d/init.d/exim restart
     
  6. utropic

    utropic Well-Known Member

    Joined:
    Aug 6, 2005
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    bumping for the same issue. Just removed clamav altogether as it prevented mail from coming/going serverwide.
     
  7. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    If it is supposed to get restarted when exim gets restarted then whatever the break is, it is more serious than it just stopping because I tried that.

    The only way I have got it back up and running is uninstall reinstall.

    I have been told to raise issues on bugtraq which unfortunately is absolutely useless to me as I have never been able to receive the confirmation email so if anyone else can get it raised that would be useful as we're not getting anywhere here!
     
  8. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    Bugtraq is only useful if you recruit a lot of people to vote for your bug.

    Cpanel must have changed something for this to stop working like this. Why can't they just change it back?
     
  9. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Do you have chkserv set to monitor clam?
     
  10. blaster701

    blaster701 Member

    Joined:
    Mar 16, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    It happened in our server as clamd couldnt update, is it related?

    update logs sent by server showed that clamd couldn't update virus definitions as connection was refused. It's the only clue as far we have found, ALL mails to all accounts are blocked since last night. We're trying to find what's wrong with clamd, if successful, we'll post our solution

    upcp updated clamav from 0.91.1 to 0.91.2, now it works properly
     
    #10 blaster701, Feb 28, 2008
    Last edited: Feb 28, 2008
Loading...
Similar Threads - Clamd crapping
  1. Bdzzld
    Replies:
    5
    Views:
    269

Share This Page