The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

clamd failed emails

Discussion in 'E-mail Discussions' started by rumor, Jul 8, 2007.

  1. rumor

    rumor Member

    Joined:
    Aug 26, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    I keep getting emails from cPanel telling me that clamd has failed, however when I check on the machine it seems like clamd is running. Any suggestions on how to correct this problem? I think this started happening along with the cPanel 11 and clamd upgrade.

    Email:
    Code:
    clamd failed @ Sat Jul  7 23:04:26 2007. A restart was attempted automagicly.
    
    Checking to see whether clamd is really running or not:
    Code:
    # ps ax | grep clam
    16109 ?        Ss     0:25 /usr/sbin/clamd
    
    # ls -l /var/clamd
    srwxrwxrwx  1 root root 0 Jul  7 23:01 /var/clamd=
    
     
  2. rumor

    rumor Member

    Joined:
    Aug 26, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    This might shed more light on the problem: it seems like it might be a problem with chkservd or the restartsrv_clamd script.

    restartsrv actually starts clamd, but wrongly says that it has failed.

    Code:
    # ps ax | grep clam
    16161 pts/0    S+     0:00 grep clam
    # /scripts/restartsrv clamd
    Waiting for clamd to restart..............finished.
    
    
    clamd has failed, please contact the sysadmin (result was "clamd is not running
    or is crashed.").
    # ps ax | grep clam
    16228 ?        Rs     0:20 /usr/sbin/clamd
    17455 pts/0    S+     0:00 grep clam
    
     
Loading...

Share This Page