The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Clamd failing

Discussion in 'General Discussion' started by fcitrolo, Feb 22, 2007.

  1. fcitrolo

    fcitrolo Active Member

    Joined:
    Dec 31, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Seems that after tonights updates clamd is failing.

    Anyone else having this problem?
     
  2. myusername

    myusername Well-Known Member
    PartnerNOC

    Joined:
    Mar 6, 2003
    Messages:
    691
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    chown -R us.*yourbase*
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Yes, on many servers. Seem to be on the STABLE builds.
     
  3. rogcan

    rogcan Well-Known Member

    Joined:
    Jun 7, 2004
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    I'm using the Current Builds and i have this problem also....

    WHM 10.8.0 cPanel 10.9.0-C138
    RedHat Enterprise 3 i686 - WHM X v3.1.0
     
  4. SiteShack

    SiteShack Member

    Joined:
    Aug 22, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Release build too is affected.
     
  5. mikelegg

    mikelegg Well-Known Member

    Joined:
    Mar 29, 2005
    Messages:
    330
    Likes Received:
    0
    Trophy Points:
    16
    Yes we're experiencing the problem with WHM 10.8.0 cPanel 10.9.0-R118

    exim_mainlog says - 2007-02-22 18:51:47 1HK9g2-0008Vr-Up malware acl condition: clamd: unable to connect to UNIX socket /var/clamd (No such file or directory)

    Quick and dirty fix is to disable the System filter file under "Exim Configuration Editor" in WHM. This is not a long term solution, but at least customers will be able to send and receive mail while we work out the proper fix.

    TOO EASY - We just re-enabled the System filter file using the default (/etc/antivirus.exim) and mail is working again!
     
    #5 mikelegg, Feb 22, 2007
    Last edited: Feb 22, 2007
  6. carnesmc

    carnesmc Registered

    Joined:
    Mar 17, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    mikelegg,

    Thanks for the info. Same problem here this morning. Your fix worked like a charm. clamd is still in a failed state but at least the mail is flowing.
     
  7. FS_Greg

    FS_Greg Member
    PartnerNOC

    Joined:
    Jun 27, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Solution

    Solution?

    All options in the clamd.conf file MUST now have a boolean argument following them. Meaning, any error messages you see, put a "yes" after it, such as:

    LogTime yes

    Whereas before, it would have just been "LogTime" on a line by itself. You can save yourself some time by going through and finding any uncommented directives that don't have this 'boolean requirement' and adding it in there before attempting to restart exim.

    This fix will bring ClamAV back to a normal state.
     
  8. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Running the following command should address the issue:

    /usr/local/cpanel/whostmgr/bin/whostmgr2 --updateaddons
     
  9. LGRCompEnt

    LGRCompEnt Registered

    Joined:
    Apr 11, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thanks!

    I woke up having this issue.

    /usr/local/cpanel/whostmgr/bin/whostmgr2 --updateaddons

    appears to have fixed it.

    Thank You.
     
  10. akasharkbow

    akasharkbow Member

    Joined:
    Apr 9, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toronto, Ontario, Canada
  11. Biotron2000

    Biotron2000 Active Member

    Joined:
    Jul 20, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    I hate to post "Me, too" like some brain-dead AOL'er, but the fix worked. Thanks!

    Patrick McNeal
     
  12. clbrack1

    clbrack1 Active Member

    Joined:
    Nov 3, 2006
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    the two steps:

    Quick and dirty fix is to disable the System filter file under "Exim Configuration Editor" in WHM. This is not a long term solution, but at least customers will be able to send and receive mail while we work out the proper fix.

    and

    /usr/local/cpanel/whostmgr/bin/whostmgr2 --updateaddons

    did not work for me and my customers are also experiencing 451 errors when Outlook (or OE) tries to send email.

    Anyone got a solution for this? I have it on some, but not all of my servers.

    Chris
     
  13. procam

    procam Well-Known Member

    Joined:
    Nov 24, 2003
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    If you are using exiscan or mailscanner you need to update ~~
    With exiscan just rerun the installer and select option 5 it will take a few min to run but it will correct this issue right away --
    then
    service exim stop
    service exim start
    and you are good~

    Our units with mailscanner did the same thing just go into mailscanner frontend and update clamav again takes a few min and its good to go~
     
  14. advantage1

    advantage1 Registered

    Joined:
    May 26, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    We were able to resolve the issue by removing and then reinstalled Clam antivirus to our WHM configuration, which appears to have resolved the issue entirely.

    Not sure if this will work for everyone's setup, but it resolved the issue completely for us.
     
  15. clbrack1

    clbrack1 Active Member

    Joined:
    Nov 3, 2006
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    did anyone else have customers complaining about 451 errors when checking email from outlook? If so how did you resolve it?

    and how do I edit the clamd.conf file, the permissions show 644 but I cannot write to the file after I edit it?

    thanks,

    Chris
     
    #15 clbrack1, Feb 22, 2007
    Last edited: Feb 22, 2007
  16. othellotech

    othellotech Member
    PartnerNOC

    Joined:
    Apr 25, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Then dont go to bed with auto-update on !

    I mean, for the price of a Cpanel VPS and a few hours *when you want to implement a new version* of doing some QA, to save screwing up your clients while you sleep is hardly much :p
     
  17. mambovince

    mambovince Well-Known Member

    Joined:
    Jan 15, 2005
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    London, UK
    Anyone else have any luck with this?

    I tried both solutions provided here:
    /usr/local/cpanel/whostmgr/bin/whostmgr2 --updateaddons

    as well as the other method of turning off and back on again the Exim system filter

    No go for my VPS running latest stable cPanel.

    Can cPanel staff reply to advise if the next auto-update will resolve this?

    Thanks,

    - Vince
     
  18. Jones

    Jones Well-Known Member

    Joined:
    Jul 10, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6


    Hello David,

    Aside from FixStaleSocket putting yes to it, please make sure also that ScanPE and other should have the yes because we are using this on all our servers also and now, it is getting an error because of this.


    Thanks,
    Jones
     
  19. Jones

    Jones Well-Known Member

    Joined:
    Jul 10, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
  20. Frankc

    Frankc Well-Known Member

    Joined:
    Jun 18, 2005
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    16
    I also have the same problem and am trying to fix it. Not very nice of Cpanel to mess-up the stable build like this.
     
Loading...

Share This Page