The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

clamd is not working

Discussion in 'General Discussion' started by binumvk, Jan 14, 2005.

  1. binumvk

    binumvk Active Member

    Joined:
    Oct 13, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    exim is trying to take more resource, when i try to shut down exim i got

    Shutting down clamd: [FAILED]
    Shutting down exim: [ OK ]
    Shutting down antirelayd: [ OK ]
    Shutting down spamd: [ OK ]
    Starting clamd: ERROR: You must select server type (local/tcp).


    here clamd is not working any solutions :mad: :mad:
     
  2. anoopkumar

    anoopkumar Member

    Joined:
    Feb 15, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    India
    just add the below line to /etc/clamd.conf

    ##
    LocalSocket /tmp/clamd
    ##

    and restart exim
     
  3. Parahosting

    Parahosting Well-Known Member

    Joined:
    Apr 6, 2007
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6

    Dude, don't you mean clamd? And by default, shouldn't clamd have that setting applied?
     
  4. one4life

    one4life Registered

    Joined:
    Oct 12, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I had to replace some missing settings on my server as follows:


    pico /etc/group

    change mail:x:12:mail

    to

    mail:x:12:mail,clamav

    Enter Exim Config in WHM and change in the middle box in the ACLs section change

    #!!# ACL that is used after the DATA command
    check_message:
    # Enabling this will make the server non-rfc compliant
    # require verify = header_sender
    accept

    to

    # ACL that is used after the DATA command
    check_message:
    # Virus Check
    deny message = This message contains a virus or other malware ($malware_name)
    demime = *
    malware = *
    accept

    the restart exim.

    It took a while to figure out but it worked for me.

    Best of luck.
     
  5. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16

    Correct is:

    LocalSocket /var/clamd

    :D
     
  6. wzd

    wzd Well-Known Member

    Joined:
    Dec 16, 2005
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    South Africa
    cPanel Access Level:
    Root Administrator
    My own experience:

    i had clamd.conf and clamd.conf.old in /usr/local/etc

    Clamd.conf was empty (0lines) so just "mv clamd.conf.old clamd.conf"
    - Seems to be working fine now,

    I have a feeling it was a corrupted install or something
     
Loading...

Share This Page