The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Clamd not configured properly

Discussion in 'General Discussion' started by reubensant, Feb 6, 2006.

  1. reubensant

    reubensant Registered

    Joined:
    May 15, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have just installed Clamd from WHM but when I try to upload any file from Cpanel's file manager I get an error message "Virus Detected; File not Uploaded! (Clamd is not configured properly.)". I am sure that the file i am uploading contains no viruses. Can anyone indicate how can I configure clamd to do this properly?

    A final question regarding clamd with cpanel. Does it only scan the files that are uploaded via the file manager and email or does it scan all files frequently? If not, can I configure it to do that?

    Thanks,

    Reuben
     
  2. FvdM

    FvdM Member

    Joined:
    Feb 7, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    @ your first question: run this command in SSH

    Code:
    clamd --config-file=/etc/clamd.conf
    If it returns an error make sure /etc/clamd.conf contains no errors. For example, you can't enable LocalSocket and TCPSocket at the same time (common mistake).
     
  3. reubensant

    reubensant Registered

    Joined:
    May 15, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    If I type the clamd command in SSH I get: clamd: Command not found.

    My /etc/clamd.conf contains only one line which is:

    FixStaleSocket

    This was automatically done by cPanel when I installed clamd. I also tried find / -name "clamd" and the only lines returned were:

    /usr/local/cpanel/src/chkservd/chkserv.d/clamd
    /var/run/chkservd/clamd
    /var/cpanel/notifications/clamd
    /etc/chkserv.d/clamd

    There is no clamd in /usr/local/bin or similar directories.

    Thanks for your help,

    Reuben
     
Loading...

Share This Page