The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

clamd not restarting

Discussion in 'General Discussion' started by claudio, Dec 4, 2005.

  1. claudio

    claudio Well-Known Member

    Joined:
    Jul 31, 2004
    Messages:
    201
    Likes Received:
    0
    Trophy Points:
    16
    Hi

    i have this server that only in this everytime i reboot the machine i have to go

    manually to /scripts/restartsrv_clamd...

    does any one know how can i made after the reboot when exim is starting to auto-start clamd together...

    kind regards

    CLaudio
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you're using the version that is available in WHM, make sure that you have the clamd process options ticked in WHM > Service Manager.
     
  3. claudio

    claudio Well-Known Member

    Joined:
    Jul 31, 2004
    Messages:
    201
    Likes Received:
    0
    Trophy Points:
    16
    Hi Jonathan

    thanks for your fast feedback again ; )

    in fact it is an old server and i am not using the whm addon i even tried this addon in a CentOs3.6 cpanel release and it gave me a message of needing a cpanel pro license, anyway... my case it is a manual installed clamav and eximscan

    i think i am going try to add into chkserv.d to see if it can restart clamav in case of being down...

    i hope than "man" or --help guides me into this task.

    well to set this av and all other scripts really takes some time...

    thanks again

    Claudio
     
  4. claudio

    claudio Well-Known Member

    Joined:
    Jul 31, 2004
    Messages:
    201
    Likes Received:
    0
    Trophy Points:
    16
    Hello Everybody

    well i just want let everybody know how i could fix this issue:

    sometimes clamav is installed (depending on the version) at /usr/local/sbin and someother times at /usr/sbin

    also its symbolic link sometimes is started at /var/run and sometimes at /var/run/clamav/

    so what i did was go into /etc/rc.d/init.d and edit the exim file

    there i replace all the paths that mentioned ClamAv for the proper path according to my system configuration..

    this worked great

    best regards

    Claudio
     
Loading...

Share This Page