Xisco

Member
May 1, 2004
10
0
151
Hi.

I get segmentation fault message when starting clamd:

Code:
[email protected] [~]# /etc/init.d/exim restart
Shutting down clamd:                                       [FAILED]
Shutting down exim:                                        [  OK  ]
Shutting down spamd:                                       [  OK  ]
Starting clamd: /bin/bash: line 1: 17031 Segmentation fault      /usr/sbin/clamd
                                                           [FAILED]
Starting exim:                                             [  OK  ]
I've reinstalled clamavconnector via "Manage plugins" without errors.

When I try to start service, clamd.log says:

Code:
+++ Started at Sun Jun 19 09:15:47 2011
clamd daemon 0.97 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
Log file size limited to 1048576 bytes.
Reading databases from /usr/share/clamav
Not loading PUA signatures.
Loaded 972336 signatures.
but service is not running...

Code:
[email protected] [~]# ps ax | grep clamd
18088 pts/1    S+     0:00 grep clamd
The server is running WHM 11.30.0 (build 32) on CENTOS 5.6 x86_64 virtuozzo and it is updated.

Any idea on how to fix this?

Thank you,
Xisco.
 

Xisco

Member
May 1, 2004
10
0
151
0.97 is outdated now more try to upgrade to 0.97.1 and maybe your issues will be solved
Thanks, k-planethost, for your answer.

I have tried to update clamd but I don't know how to do it in WHM. I think the only way is using git and latest repository. I don't know how to deal with it in cPanel.

Despite this, I have another cPanel server running clamd 0.97 without problems, so I don't think the problem is in the version used:

Code:
[[email protected] ~]# cat /tmp/clamd.log 
+++ Started at Sun Jun 19 10:37:39 2011
clamd daemon 0.97 (OS: linux-gnu, ARCH: i386, CPU: i686)
Log file size limited to 1048576 bytes.
Reading databases from /usr/share/clamav
Not loading PUA signatures.
Loaded 972336 signatures.
LOCAL: Unix socket file /var/clamd
LOCAL: Setting connection queue length to 200
Limits: Global size limit set to 104857600 bytes.
Limits: File size limit set to 26214400 bytes.
Limits: Recursion level limit set to 16.
Limits: Files limit set to 10000.
Archive support enabled.
Algorithmic detection enabled.
Portable Executable support enabled.
ELF support enabled.
Mail files support enabled.
OLE2 support enabled.
PDF support enabled.
HTML support enabled.
Self checking every 600 seconds.
Best regards,
Xisco.
 

JawadArshad

Well-Known Member
PartnerNOC
Apr 8, 2008
459
7
68
PK
cPanel Access Level
DataCenter Provider
Have you attempted an earlier install via some other source than cPanel. If so, remove clamav from cPanel, run the two commands below and then reinstall clamavconnector from WHM again.

rm -f /usr/lib/libclam*
rm -f /usr/local/lib/libclam*

Thanks, k-planethost, for your answer.

I have tried to update clamd but I don't know how to do it in WHM. I think the only way is using git and latest repository. I don't know how to deal with it in cPanel.

Despite this, I have another cPanel server running clamd 0.97 without problems, so I don't think the problem is in the version used:

Code:
[[email protected] ~]# cat /tmp/clamd.log 
+++ Started at Sun Jun 19 10:37:39 2011
clamd daemon 0.97 (OS: linux-gnu, ARCH: i386, CPU: i686)
Log file size limited to 1048576 bytes.
Reading databases from /usr/share/clamav
Not loading PUA signatures.
Loaded 972336 signatures.
LOCAL: Unix socket file /var/clamd
LOCAL: Setting connection queue length to 200
Limits: Global size limit set to 104857600 bytes.
Limits: File size limit set to 26214400 bytes.
Limits: Recursion level limit set to 16.
Limits: Files limit set to 10000.
Archive support enabled.
Algorithmic detection enabled.
Portable Executable support enabled.
ELF support enabled.
Mail files support enabled.
OLE2 support enabled.
PDF support enabled.
HTML support enabled.
Self checking every 600 seconds.
Best regards,
Xisco.
 

Xisco

Member
May 1, 2004
10
0
151
Have you attempted an earlier install via some other source than cPanel.
No, I haven't.

If so, remove clamav from cPanel, run the two commands below and then reinstall clamavconnector from WHM again.

rm -f /usr/lib/libclam*
rm -f /usr/local/lib/libclam*
All these files were deleted by uninstall process. clamd still fails.

Thank you, JawadArshad.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
At this point in time, please open up a ticket using WHM > Support Center > Contact cPanel or using the link in my signature for us to investigate further. Please post the ticket number here upon submitting one. Thanks!

Also, please check the WHM > Tweak Settings area for this setting:

Max cPanel process memory (minimum: 256)
If it is only set to 256, please increase to either unlimited or at least 512MB and save that area. Then try uninstalling and reinstalling clamav connector in WHM > Manage Plugins area again.
 

Xisco

Member
May 1, 2004
10
0
151
At this point in time, please open up a ticket using WHM > Support Center > Contact cPanel or using the link in my signature for us to investigate further. Please post the ticket number here upon submitting one. Thanks!
Done. Request #1650454

Also, please check the WHM > Tweak Settings area for this setting:

If it is only set to 256, please increase to either unlimited or at least 512MB and save that area. Then try uninstalling and reinstalling clamav connector in WHM > Manage Plugins area again.
It was "unlimited" yet. This was one of the changes I made trying to solve this.

Thank you,
Xisco.