The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

clamd: Segmentation fault

Discussion in 'General Discussion' started by Xisco, Jun 19, 2011.

  1. Xisco

    Xisco Member

    Joined:
    May 1, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hi.

    I get segmentation fault message when starting clamd:

    Code:
    root@noa [~]# /etc/init.d/exim restart
    Shutting down clamd:                                       [FAILED]
    Shutting down exim:                                        [  OK  ]
    Shutting down spamd:                                       [  OK  ]
    Starting clamd: /bin/bash: line 1: 17031 Segmentation fault      /usr/sbin/clamd
                                                               [FAILED]
    Starting exim:                                             [  OK  ]
    
    I've reinstalled clamavconnector via "Manage plugins" without errors.

    When I try to start service, clamd.log says:

    Code:
    +++ Started at Sun Jun 19 09:15:47 2011
    clamd daemon 0.97 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
    Log file size limited to 1048576 bytes.
    Reading databases from /usr/share/clamav
    Not loading PUA signatures.
    Loaded 972336 signatures.
    
    but service is not running...

    Code:
    root@noa [~]# ps ax | grep clamd
    18088 pts/1    S+     0:00 grep clamd
    
    The server is running WHM 11.30.0 (build 32) on CENTOS 5.6 x86_64 virtuozzo and it is updated.

    Any idea on how to fix this?

    Thank you,
    Xisco.
     
  2. k-planethost

    k-planethost Well-Known Member

    Joined:
    Sep 22, 2009
    Messages:
    199
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Athens Greece
    0.97 is outdated now more try to upgrade to 0.97.1 and maybe your issues will be solved
     
  3. Xisco

    Xisco Member

    Joined:
    May 1, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Thanks, k-planethost, for your answer.

    I have tried to update clamd but I don't know how to do it in WHM. I think the only way is using git and latest repository. I don't know how to deal with it in cPanel.

    Despite this, I have another cPanel server running clamd 0.97 without problems, so I don't think the problem is in the version used:

    Code:
    [root@ponent ~]# cat /tmp/clamd.log 
    +++ Started at Sun Jun 19 10:37:39 2011
    clamd daemon 0.97 (OS: linux-gnu, ARCH: i386, CPU: i686)
    Log file size limited to 1048576 bytes.
    Reading databases from /usr/share/clamav
    Not loading PUA signatures.
    Loaded 972336 signatures.
    LOCAL: Unix socket file /var/clamd
    LOCAL: Setting connection queue length to 200
    Limits: Global size limit set to 104857600 bytes.
    Limits: File size limit set to 26214400 bytes.
    Limits: Recursion level limit set to 16.
    Limits: Files limit set to 10000.
    Archive support enabled.
    Algorithmic detection enabled.
    Portable Executable support enabled.
    ELF support enabled.
    Mail files support enabled.
    OLE2 support enabled.
    PDF support enabled.
    HTML support enabled.
    Self checking every 600 seconds.
    
    Best regards,
    Xisco.
     
  4. JawadArshad

    JawadArshad Well-Known Member
    PartnerNOC

    Joined:
    Apr 8, 2008
    Messages:
    447
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    PK
    cPanel Access Level:
    DataCenter Provider
    Have you attempted an earlier install via some other source than cPanel. If so, remove clamav from cPanel, run the two commands below and then reinstall clamavconnector from WHM again.

    rm -f /usr/lib/libclam*
    rm -f /usr/local/lib/libclam*

     
  5. Xisco

    Xisco Member

    Joined:
    May 1, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    No, I haven't.

    All these files were deleted by uninstall process. clamd still fails.

    Thank you, JawadArshad.
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    At this point in time, please open up a ticket using WHM > Support Center > Contact cPanel or using the link in my signature for us to investigate further. Please post the ticket number here upon submitting one. Thanks!

    Also, please check the WHM > Tweak Settings area for this setting:

    If it is only set to 256, please increase to either unlimited or at least 512MB and save that area. Then try uninstalling and reinstalling clamav connector in WHM > Manage Plugins area again.
     
  7. Xisco

    Xisco Member

    Joined:
    May 1, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Done. Request #1650454

    It was "unlimited" yet. This was one of the changes I made trying to solve this.

    Thank you,
    Xisco.
     
  8. Xisco

    Xisco Member

    Joined:
    May 1, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Solved by Amir. He made a fresh install after removing /usr/share/clamav/ directory.

    Thaks,
    Xisco.
     
Loading...

Share This Page