The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

clamd service error

Discussion in 'General Discussion' started by upsforum, Oct 21, 2015.

  1. upsforum

    upsforum Well-Known Member

    Joined:
    Jul 27, 2005
    Messages:
    446
    Likes Received:
    0
    Trophy Points:
    16
    Code:
    Waiting for âclamdâ
                       â¦failed.
    
    Service Error
            The âclamdâ
    
    Startup Log
            Starting Clam AntiVirus Daemon: ERROR: TCP: bind() error when trying to listen on [127.0.0.1]:3310: Address already in use
            ERROR: LOCAL: Socket file /var/run/clamav/clamd.sock is in use by another process.
            [FAILED]
    
    clamd has failed. Contact your system administrator if the service does not automagically recover.
    
    I have a problem with clamd service, I try with

    # /usr/local/cpanel/scripts/restartsrv_clamd

    but get this error:
     
  2. David P. Levey Jr.

    Joined:
    Oct 10, 2015
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Alabama, United States
    cPanel Access Level:
    Root Administrator
    Check your already running processes. See if clamd is already running (and possibly started by another user/system call).

    Code:
    ps auxf |grep clam |grep -v grep
    If there is another instance, kill it first.

    Eg.
    Code:
    root     29698  0.0  2.4 359024 202924 ?       Ssl  08:37   0:00 /usr/local/cpanel/3rdparty/bin/clamd
    
    kill -9 29698
    

    You should be able to then successfully restart it.

    Code:
    /scripts/restartsrv_clamd
    Waiting for “clamd” to start ……waiting for “clamd” to initialize ……
    …finished.
    
    Startup Log
        Oct 21 08:43:30 localhost systemd[1]: Starting clamd antivirus daemon...
        Oct 21 08:43:41 localhost systemd[1]: Started clamd antivirus daemon.
    
    clamd started successfully.
    
     
  3. upsforum

    upsforum Well-Known Member

    Joined:
    Jul 27, 2005
    Messages:
    446
    Likes Received:
    0
    Trophy Points:
    16
    this is result

    Code:
    root@carvin [~]# /scripts/restartsrv_clamd
    Waiting for âclamdâ
    
    
    â¦failed.
    
    Service Error
            The âclamdâ
    
    Startup Log
            Starting Clam AntiVirus Daemon: [  OK  ]
    
    clamd has failed. Contact your system administrator if the service does not automagically recover.
     
  4. David P. Levey Jr.

    Joined:
    Oct 10, 2015
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Alabama, United States
    cPanel Access Level:
    Root Administrator
    How about the output from:
    Code:
    ps auxf |grep clam |grep -v grep
    Also, have you confirmed that clamav is installed?

    Another thing to check is make sure nothing else is listening (besides clam) on port 3310.
    Code:
    sudo netstat -tulpn |grep 3310
     
  5. upsforum

    upsforum Well-Known Member

    Joined:
    Jul 27, 2005
    Messages:
    446
    Likes Received:
    0
    Trophy Points:
    16
    Code:
    root@carvin [/home/carvin]# ps auxf |grep clam |grep -v grep
    root     11708  2.8  7.8 694976 309688 ?       Ssl  03:39   9:10 /usr/local/cpanel/3rdparty/bin/clamd
    root@carvin [/home/carvin]# sudo netstat -tulpn |grep 3310
    root@carvin [/home/carvin]#
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  7. upsforum

    upsforum Well-Known Member

    Joined:
    Jul 27, 2005
    Messages:
    446
    Likes Received:
    0
    Trophy Points:
    16
    now work fine, thank you
     
  8. David P. Levey Jr.

    Joined:
    Oct 10, 2015
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Alabama, United States
    cPanel Access Level:
    Root Administrator
    That's great news! For other members that may be experiencing similar issues can you please confirm the resolution to this issue?
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I've seen this happen in the past when a third-party instance of ClamAV was installed on the system.

    Thank you.
     
Loading...

Share This Page