clamd wan't work with "LogTime" option enabled...

dexus

Well-Known Member
Jan 14, 2006
180
11
168
cPanel Access Level
Root Administrator
Hello,

After last cPanel upgrade, my clamd was not able to start again, when I tried to restart it manualy I received following message:

Code:
Starting clamd: ERROR: Parse error at line 34: Option LogTime requires boolean argument.
I checked and found the following in conf file:

Code:
32 # Log time with each message.
33 # Default: disabled
34 LogTime
so I changed row 34 to:

Code:
#LogTime
and it's now working.

I also checked on my other servers and I have this option also uncomented(enabled) on all servers and it's working without problems.

What can be a problem here??

Thanks.
 

dexus

Well-Known Member
Jan 14, 2006
180
11
168
cPanel Access Level
Root Administrator
I found a reason and solution for this problem.

Configuration has changed in ClamAV since version 0.9 and every boolean option now need to have "yes" or "no" parametar, like this:

Code:
LogTime yes
and problem is that cPanel upcp doesn't fix /etc/clamd.conf file...
 
Last edited:

jayh38

Well-Known Member
Mar 3, 2006
1,213
0
166
yes, this is required for most setings like that. The latest updates should fix that as well.

/usr/local/cpanel/whostmgr/bin/whostmgr2 --updateaddons
 

jayh38

Well-Known Member
Mar 3, 2006
1,213
0
166
Ok, this has been discussed extensively the past few days. Every updated box seems to update fine on its own but there were a few that needed manual attention.
 

dexus

Well-Known Member
Jan 14, 2006
180
11
168
cPanel Access Level
Root Administrator
No, none of them updates fine, just the servers that doesn't have any option that require boolean argument in clamd.conf enabled(uncomented) are working fine. cPanel upgrade just don't change anything in clamd.conf file.