The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Clamd

Discussion in 'General Discussion' started by Daky, May 3, 2007.

  1. Daky

    Daky Well-Known Member

    Joined:
    May 22, 2005
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hi,
    How can i make sure that my CLAMD is scanning all incoming and outgoing messages from my exim?

    Thanks!
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    If you are using the clamavconnector in whm, this should appear




    deny message = This message contains a virus or other harmful content ($malware_name)
    malware = *




    when running the following command


    grep malware /etc/exim.conf
     
  3. Daky

    Daky Well-Known Member

    Joined:
    May 22, 2005
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Yes, it is installed in whm, but i dont get what you just mentioned.

    root@server1 [~]# grep malware /etc/exim.conf
    root@server1 [~]#

    What should i do?

    Thank you sir!
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
  5. Daky

    Daky Well-Known Member

    Joined:
    May 22, 2005
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    ah, so its something complicated :(

    tnx
     
  6. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Or just not apparent with the tiny bit of information that can be provided here :eek: .
     
  7. Daky

    Daky Well-Known Member

    Joined:
    May 22, 2005
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Understand.

    Thank you sir, doing that now! :)
     
  8. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Nick,

    Upgraded clamd from WHM and got wacked. Any clue what needs to be done to get it corrected and running again?

    usr/bin/ld: warning: libssl.so.4, needed by /usr/lib/libcurl.so, may conflict with libssl.so.3
    /usr/bin/ld: warning: libcrypto.so.4, needed by /usr/lib/libcurl.so, may conflict with libcrypto.so.3
    network.o(.text+0x2b): In function `r_gethostbyname':
    ../shared/network.c:78: undefined reference to `gethostbyname_r'
    thrmgr.o(.text+0xa5): In function `thrmgr_destroy':
    /usr/local/cpanel/modules-install/clamavconnector-FreeBSD-i386/clamav-0.90.2/clamd/thrmgr.c:127: undefined reference to `pthread_attr_destroy'
    thrmgr.o(.text+0x18b): In function `thrmgr_new':
    /usr/local/cpanel/modules-install/clamavconnector-FreeBSD-i386/clamav-0.90.2/clamd/thrmgr.c:168: undefined reference to `pthread_attr_init'
    thrmgr.o(.text+0x19d):/usr/local/cpanel/modules-install/clamavconnector-FreeBSD-i386/clamav-0.90.2/clamd/thrmgr.c:176: undefined reference to `pthread_attr_setdetachstate'
    thrmgr.o(.text+0x1ed):/usr/local/cpanel/modules-install/clamavconnector-FreeBSD-i386/clamav-0.90.2/clamd/thrmgr.c:177: undefined reference to `pthread_attr_destroy'
    thrmgr.o(.text+0x28b): In function `thrmgr_worker':
    /usr/local/cpanel/modules-install/clamavconnector-FreeBSD-i386/clamav-0.90.2/clamd/thrmgr.c:217: undefined reference to `pthread_cond_timedwait'
    thrmgr.o(.text+0x483): In function `thrmgr_dispatch':
    /usr/local/cpanel/modules-install/clamavconnector-FreeBSD-i386/clamav-0.90.2/clamd/thrmgr.c:290: undefined reference to `pthread_create'
    *** Error code 1

    Stop in /usr/local/cpanel/modules-install/clamavconnector-FreeBSD-i386/clamav-0.90.2/clamd.
    *** Error code 1

    Stop in /usr/local/cpanel/modules-install/clamavconnector-FreeBSD-i386/clamav-0.90.2.
    ln: ./freshclam: File exists
    ./install: /usr/bin/freshclam: not found
    No matching processes were found
    No matching processes were found
    ./install: /usr/sbin/clamd: not found
    Killed
    Killed
     
  9. basfrishert

    basfrishert Registered

    Joined:
    Oct 30, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Same problem

    Same problem here.
    Is there anyone who knows the solution?
     
  10. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    I found that when using the clamav addon through the WHM that whenever clam was updated, that the av_scanner line in the exim.conf file would disappear.

    If you are having trouble with clamav with exim and you are using the clamav connector addon, see if your exim.conf file has the line:

    av_scanner = clamd:/var/clamd

    near the top.

    If it does not, try using the exim configuration editor and adding that line in the top box.

    Not sure if this is an oversight on cPanel's part. Haven't investigated this with cPanel 11. And this could just be something that I am not doing correctly.
     
  11. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16

    Nope, our exim config has the line av_scanner = clamd:/var/clamd...this is a problem with the new release as it was woking prior to it. Looks like conflicting library files...Was hoping Nick would chim in though...:(
     
  12. lobotecario

    lobotecario Registered

    Joined:
    Apr 18, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    clamd restart

    please need solve this message but i have not idea:
    clamd failed @ Fri Apr 18 11:46:05 2008. A restart was attempted automagically.

    help, thanks
     
  13. alex318

    alex318 Member

    Joined:
    Jun 4, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    If you have recently updated WHM and clamd failed all the time after update, please check your clamd conf file /etc/clamd.conf

    Find the line that said:

    ArchiveMaxCompressionRatio 0

    Commented that line and save the file. Restart Exim and everything should be fine.
     
Loading...

Share This Page