The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Clean WHM Installation: MySQL wont allow user to connect

Discussion in 'Database Discussions' started by sunnyzunnie, Dec 5, 2015.

  1. sunnyzunnie

    sunnyzunnie Registered

    Joined:
    Dec 5, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Netherlands
    cPanel Access Level:
    Root Administrator
    Hello,

    i have just finished ordering a clean VPS with CentOS 6 and a WHM installation.
    I have created an account for our website and a database for the forums, the user was added to this database too with priveleges.
    However, i cannot get the forums to connect to the database. It keeps saying access denied for user xxx using password yes.
    Remote MySQL is also not working when i set IP's in it and then try to connect to it.
    Only thing that works is PHPMyAdmin on the domain cpanel.
    Anyone know what is up with this?
    Thanks for any help :)
     
  2. faisalnoufal

    faisalnoufal Registered

    Joined:
    Dec 5, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Cochin
    cPanel Access Level:
    Root Administrator
    I am getting the same...:(
     
  3. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello :),

    Have you tried to reset your mysql password ? Please try to reset that and try login your mysql user through command line

    Code:
    mysql -uUSER_NAME -p
     
  4. divyac

    divyac Registered

    Joined:
    Nov 22, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Reset the password for the user xxx from cpanel >> Mysql Databases and make sure to add the same password in the configuration file of the forum in your site. Make sure that you have added correct IP for remote access at Remote Mysql in cpanel.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,682
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Are you correctly entering the database name and database username in the script's configuration file? Ensure you include the database prefix if that's what's listed in the database name and database username.

    Thank you.
     
Loading...

Share This Page