Clearing cached DNS on server?

whipworks

Well-Known Member
Aug 19, 2014
169
7
68
cPanel Access Level
Reseller Owner
Is there such a thing? For some reason, an email account is not seeing another email account from a different server. It's stating as "No Such User", but in fact that email exist. I'm wondering if this is a DNS issue. I've checked the zone records of the other account and everything is there (A, TXT, NS, and MX records). So why is the server not seeing that account?
 

24x7ss

Well-Known Member
Sep 30, 2014
272
17
68
India
cPanel Access Level
Root Administrator
Twitter
Hello:)

It seems to be an issue with MX Settings for the sender domain. Did you check if the MX for sender domain is set to remote ? if yes, make sure it is not added in /etc/localdomains but in /etc/remotedomains.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
Hello :)

Yes, it seems likely the domain name the user is sending to exists on the local machine in the /etc/localdomains file. You should use the "Edit DNS Zone" feature in WHM to change the "Email Routing" setting to "Remote Mail Exchanger" if that's the case.

Thank you.
 

whipworks

Well-Known Member
Aug 19, 2014
169
7
68
cPanel Access Level
Reseller Owner
Hello:)

It seems to be an issue with MX Settings for the sender domain. Did you check if the MX for sender domain is set to remote ? if yes, make sure it is not added in /etc/localdomains but in /etc/remotedomains.
The MX entry is set to Local Mail Exchange.
 

whipworks

Well-Known Member
Aug 19, 2014
169
7
68
cPanel Access Level
Reseller Owner
Hello :)

Yes, it seems likely the domain name the user is sending to exists on the local machine in the /etc/localdomains file. You should use the "Edit DNS Zone" feature in WHM to change the "Email Routing" setting to "Remote Mail Exchanger" if that's the case.

Thank you.
Would this break the incoming mails?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
I apologize for any confusion. I'm suggesting the sending server that's receiving the "no such user here" message has added your domain name as an account on their server, and thus it's looking for the local email account. Do you control both servers?

Thank you.
 

whipworks

Well-Known Member
Aug 19, 2014
169
7
68
cPanel Access Level
Reseller Owner
No. We only control the sending server. So this problem is on the receiving server? How do they fix it? For some reason they are blaming us for it. I'm trying to think if the migration process have anything to do with it. The receiving account was once on our server and they moved it out.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
The receiving account was once on our server and they moved it out.
Check to see if the domain name handled on the receiving server is in your /etc/localdomains file. If so, remove it, and remove any DNS zone associated with it from your system.

Thank you.
 

whipworks

Well-Known Member
Aug 19, 2014
169
7
68
cPanel Access Level
Reseller Owner
I've actually suspended the account and removed any DNS record entries. Have no access to /etc/localdomains via SSH. Can't understand why I don't have permission when I'm logging in as root, or I'm probably doing it wrong. I'm pretty new at this.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
I've actually suspended the account and removed any DNS record entries. Have no access to /etc/localdomains via SSH. Can't understand why I don't have permission when I'm logging in as root, or I'm probably doing it wrong. I'm pretty new at this.
You can edit it with a command such as:

Code:
vi /etc/localdomains
Ensure you are logged in with root access.

Thank you.