The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Client domain changed in WHM, but files not showing up?

Discussion in 'General Discussion' started by niemie, Nov 2, 2006.

  1. niemie

    niemie Registered

    Joined:
    Aug 24, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I had a client who let their domain expire, but had another one already purchased which had the dns set up correctly prior. I changed the domain by modifying the account on WHM. Now though, the new domain is for some reason brining up MY website vs the clients, who's files are obviously still the same.

    I'm not sure why this is happening or how to fix it. Any ideas>

    Thanks in advance.
     
  2. sparksupport

    sparksupport Member

    Joined:
    Apr 30, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    The issue seems to be with the server apache configuration. Open your httpd.conf file and make sure the new domain name is correctly updated there
     
  3. Rycon Payne

    Rycon Payne Registered

    Joined:
    Feb 2, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I am having the same issue here. I updated the domain of a user, and his site now points to my hosting page. As my colo told me, I checked httpd.conf and found that two lines of the virtual_host for his accounts still had the old domain name. I changed it, restarted apache (several times), and it didn't fix the issue.

    I've searched all over the server for some reason for this to be happening, and I can't find it.

    Edit: Maybe this is connected? http://bugzilla.cpanel.net/show_bug.cgi?id=4772
     
  4. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    Make sure that the httpd.conf virtualhost and the /var/named/domain.com.db dns files (or external dns) match. If it is pointing to the wrong IP you will have this problem.
     
Loading...

Share This Page