The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Clocksource tsc unstable on CentOS and cloud Linux with Hyper-V Virtualisation

Discussion in 'Workarounds and Optimization' started by Neutrall, Sep 10, 2014.

  1. Neutrall

    Neutrall Member
    PartnerNOC

    Joined:
    Jul 22, 2014
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    DataCenter Provider
    We’ve had some problem on our cPanel servers lately.

    We’ve notice that in the messages log (/var/log/messages) we had about 2 or 3 entry per second :eek: concerning the unstable clock source:

    Code:
    Sep 10 11:26:37 web25 kernel: [355613.963016] Clocksource tsc unstable (delta = -115600910 ns).  Enable clocksource failover by adding clocksource_failover kernel parameter.
    Sep 10 11:26:37 web25 kernel: [355614.463025] Clocksource tsc unstable (delta = -115384176 ns).  Enable clocksource failover by adding clocksource_failover kernel parameter.
    Sep 10 11:26:38 web25 kernel: [355614.963033] Clocksource tsc unstable (delta = -115384725 ns).  Enable clocksource failover by adding clocksource_failover kernel parameter.
    Sep 10 11:26:38 web25 kernel: [355615.463041] Clocksource tsc unstable (delta = -115384418 ns).  Enable clocksource failover by adding clocksource_failover kernel parameter.
    Sep 10 11:26:39 web25 kernel: [355615.963052] Clocksource tsc unstable (delta = -115385309 ns).  Enable clocksource failover by adding clocksource_failover kernel parameter.
    Sep 10 11:26:39 web25 kernel: [355616.463058] Clocksource tsc unstable (delta = -115384416 ns).  Enable clocksource failover by adding clocksource_failover kernel parameter.
    Sep 10 11:26:40 web25 kernel: [355616.962068] Clocksource tsc unstable (delta = -115153928 ns).  Enable clocksource failover by adding clocksource_failover kernel parameter.
    Rebooting the server solves the error, but as soon as the VM is moved from one node to another in our cluster, the CPU clock seems to be desynchronised. In the past, only moving the server back to its original node or rebooting the VM worked :confused:.

    We’ve tried many solution and finally found one that worked :D. If any of you have the same problem, here how we’ve solved the issue.

    We’ve added the acpi_pm as a failover clock source. To do so, we’ve edited the gub.conf (/boot/grub/grub.conf) and added the “clocksource_failover=acpi_pm” line at the end of the line containing the kernel information EX :

    Code:
    kernel /vmlinuz-2.6.32-379.22.1.lve1.2.17.1.el6.x86_64 ro root=/dev/mapper/vg_stm4-lv_root rd_NO_LUKS rd_LVM_LV=vg_stm4/lv_swap LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=vg_stm4/lv_root SYSFONT=latarcyrheb-sun16 crashkernel=auto  KEYB $  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet nohz=off clocksource_failover=acpi_pm
    Once the line is added, we reboot the Server.

    Since we’ve added the failover clocksource, moving the server from one node to a other in our Hyper-V cluster is no longer causing the error message.

    …. The only thing left, I wonder is … I think that the line will need to be added at every kernel update? (Correct me if I’m wrong!)
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Thank you for sharing this workaround. Please note that user-submitted workarounds are not tested or supported by cPanel. We encourage everyone to review all aspects of workarounds before implementing them on a production server.

    Thank you.
     

Share This Page