The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Cloudflare and external email server

Discussion in 'E-mail Discussions' started by jimlongo, Mar 26, 2017.

Tags:
  1. jimlongo

    jimlongo Well-Known Member

    Joined:
    Mar 20, 2008
    Messages:
    160
    Likes Received:
    3
    Trophy Points:
    68
    Wondering if anyone has any insights on this.

    I've setup Cloudflare to provide A records for my domain. (rdiv.com -> orange cloud)
    I have a CNAME record for mail that is not passing through CF, and I've also tried this as an A record. (grey cloud)

    I use SpamExperts.com for email, I have added MX records at Cloudflare that match what I was using before in my cPanel DNS zone.

    Code:
    MX  rdiv.com mail.spamexperts.com   10
    MX rdiv.com fallbackmx.spamexperts.eu 20
    MX rdiv.com lastmx.spamexperts.net    30
    
    I have also tried using 'mail' in place of 'rdiv.com' in the above MX records as suggested by this CF article, but when I do that I get no MX records when I check with dig.

    I have tried both Local and Remote mail exchangers in my DNS Zone editor in WHM.

    I have mod_cloudflare installed
    I have flexible SSL provided by CF
    I have DNSSEC provided by CF
     
    #1 jimlongo, Mar 26, 2017
    Last edited: Mar 26, 2017
  2. jimlongo

    jimlongo Well-Known Member

    Joined:
    Mar 20, 2008
    Messages:
    160
    Likes Received:
    3
    Trophy Points:
    68
    Finally figured it out.

    SpamExperts has a route setting that would normally be rdiv.com port 25.

    Cloudflare says you can no longer use rdiv.com for the mail server as this is being proxied by CF.

    The solution is to setup a CNAME record at CF for something like mail.rdiv.com.
    Code:
    CNAME  mail        is an alias of rdiv.com    (grey cloud)
    MX     rdiv.com    mail.spamexperts.com        10
    MX     rdiv.com    fallbackmx.spamexperts.eu   20
    MX     rdiv.com    lastmx.spamexperts.net      30
    
    Then at SpamExperts use this as the route setting mail.rdiv.com port 25. (Edit: SpamExperts support said I could use my serverIP as the routing address, but I have not confirmed that that works.)

    Continue to use Local Mail Exchanger within WHM.


    Hope that helps someone else.
     
    #2 jimlongo, Mar 26, 2017
    Last edited: Mar 27, 2017
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,297
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm happy to see you were able to address the issue. Thank you for updating us with the outcome.
     
Loading...

Share This Page