The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cloudflare plugin doesn't show up

Discussion in 'General Discussion' started by slinky, Dec 23, 2016.

  1. slinky

    slinky Well-Known Member

    Joined:
    Jul 26, 2007
    Messages:
    71
    Likes Received:
    1
    Trophy Points:
    58
    #1 slinky, Dec 23, 2016
    Last edited by a moderator: Mar 7, 2017
  2. cPanelChrisI

    cPanelChrisI Technical Analyst II
    Staff Member

    Joined:
    Mar 24, 2014
    Messages:
    67
    Likes Received:
    11
    Trophy Points:
    83
    cPanel Access Level:
    Root Administrator
    Hello!

    Since the Cloudflare plugin is not developed or supported by cPanel, it may be best to get with their support for any issues you have with that. I do see some instances where installing that manually using the install.json file in the Cloudflare plugin package allowed that to be installed correctly. Can you try finding that file in the installation package that you downloaded, then use this command to install that as per our documentation for plugins at Guide to cPanel Plugins - Software Development Kit - cPanel Documentation

    Code:
    /usr/local/cpanel/scripts/install_plugin /path/only/to/install.json/file/ --theme paper_lantern
    Note that I didn't add the file name at the end of the path, only the path to it. Can you verify if that allows that to install properly?

    Thanks!
     
  3. slinky

    slinky Well-Known Member

    Joined:
    Jul 26, 2007
    Messages:
    71
    Likes Received:
    1
    Trophy Points:
    58
    Thanks for your reply. Yes, I realized the challenge of supporting a third party plugin (even if popular) and will see what I can do using the information above. The Cloudflare package installed, confirmed OK and even checking a version number came back with the proper respond. The installation doesn't seem to leave any files in /usr/local/cpanel/scripts/ but I'll see what I can do.

    Originally I tried the following instructions too, which didn't work - which I only now realize are someone else's attempt to use a similar domain name. I received a bash unknown or unrecognized command, can't recall exactly what.
     
  4. cPanelChrisI

    cPanelChrisI Technical Analyst II
    Staff Member

    Joined:
    Mar 24, 2014
    Messages:
    67
    Likes Received:
    11
    Trophy Points:
    83
    cPanel Access Level:
    Root Administrator
    Thanks for the update. Were you able to make any progress on this since your post?
     
Loading...

Share This Page