Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

CloudLinux 7.4 + cPanel 68 failing

Discussion in 'CloudLinux' started by globaluty, Feb 15, 2018.

Tags:
  1. globaluty

    globaluty Registered

    Joined:
    Feb 15, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bulgaria
    cPanel Access Level:
    Website Owner
    Hello, guys.

    I got freshly new installed linux server with CloudLinux 7.4 and i am trying ot install cpanel.

    Everytime the installation results in this:
    Code:
    
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-forks-0.36-1.cp1162.x86_64.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-Math-Fibonacci-1.5-1.cp1162.x86_64.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-Net-Daemon-SSL-1.0-1.cp1162.x86_64.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-Data-Section-0.200006-1.cp1162.x86_64.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-Test-ClassAPI-1.06-1.cp1162.x86_64.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-Algorithm-Dependency-1.110-1.cp1162.x86_64.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-Sys-Info-Driver-Linux-0.7903-1.cp1162.x86_64.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-HTTP-Headers-Fast-0.21-1.cp1162.noarch.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-IO-Socket-IP-0.39-1.cp1162.noarch.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-GSSAPI-0.28-1.cp1162.x86_64.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-Module-Refresh-0.17-1.cp1162.x86_64.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-Sub-Exporter-Progressive-0.001013-1.cp1162.noarch.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-php56-Horde-Compress-Fast-1.1.1-1.cp1158.noarch.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   cpanel-perl-524-Exporter-Tiny-0.044-1.cp1162.noarch.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   exim-4.89.1-2.cp1162.x86_64.rpm already downloaded
    [2018-02-15 13:13:00 +0200]   All files Staged
    [2018-02-15 13:13:00 +0200]   Testing if the newly downloaded RPMS can be installed without conflict
    [2018-02-15 13:13:00 +0200]   Testing RPM transaction
    [2018-02-15 13:13:00 +0200]   error: Failed dependencies:
    [2018-02-15 13:13:00 +0200]     pango is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     fontconfig is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     cairo is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     pixman is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     gd >= 2.0.28 is needed by cpanel-perl-524-GD-2.56-1.cp1168.x86_64
    [2018-02-15 13:13:00 +0200]     gd is needed by cpanel-php56-5.6.30-2.cp1164.x86_64
    [2018-02-15 13:13:00 +0200]     libXpm is needed by cpanel-php56-5.6.30-2.cp1164.x86_64
    [2018-02-15 13:13:00 +0200]     libtool-ltdl is needed by cpanel-php56-5.6.30-2.cp1164.x86_64
    [2018-02-15 13:13:00 +0200]     gd is needed by cpanel-webalizer-2.23_08-1.cp1168.x86_64
    [2018-02-15 13:13:00 +0200]     libgd.so.2()(64bit) is needed by cpanel-webalizer-2.23_08-1.cp1168.x86_64
    [2018-02-15 13:13:00 +0200]     libicudata.so.50()(64bit) is needed by dovecot-2.2.33.2-3.cp1162.x86_64
    [2018-02-15 13:13:00 +0200]     libicui18n.so.50()(64bit) is needed by dovecot-2.2.33.2-3.cp1162.x86_64
    [2018-02-15 13:13:00 +0200]     libicuuc.so.50()(64bit) is needed by dovecot-2.2.33.2-3.cp1162.x86_64
    [2018-02-15 13:13:00 +0200] W Exit Code: 254
    [2018-02-15 13:13:00 +0200] ***** FATAL: Test install failed: error: Failed dependencies:
    [2018-02-15 13:13:00 +0200]     pango is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     fontconfig is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     cairo is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     pixman is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     gd >= 2.0.28 is needed by cpanel-perl-524-GD-2.56-1.cp1168.x86_64
    [2018-02-15 13:13:00 +0200]     gd is needed by cpanel-php56-5.6.30-2.cp1164.x86_64
    [2018-02-15 13:13:00 +0200]     libXpm is needed by cpanel-php56-5.6.30-2.cp1164.x86_64
    [2018-02-15 13:13:00 +0200]     libtool-ltdl is needed by cpanel-php56-5.6.30-2.cp1164.x86_64
    [2018-02-15 13:13:00 +0200]     gd is needed by cpanel-webalizer-2.23_08-1.cp1168.x86_64
    [2018-02-15 13:13:00 +0200]     libgd.so.2()(64bit) is needed by cpanel-webalizer-2.23_08-1.cp1168.x86_64
    [2018-02-15 13:13:00 +0200]     libicudata.so.50()(64bit) is needed by dovecot-2.2.33.2-3.cp1162.x86_64
    [2018-02-15 13:13:00 +0200]     libicui18n.so.50()(64bit) is needed by dovecot-2.2.33.2-3.cp1162.x86_64
    [2018-02-15 13:13:00 +0200]     libicuuc.so.50()(64bit) is needed by dovecot-2.2.33.2-3.cp1162.x86_64
    [2018-02-15 13:13:00 +0200]   The Administrator will be notified to review this output when this script completes
    [2018-02-15 13:13:00 +0200] ***** FATAL: Error testing if the RPMs will install: Test install failed: error: Failed dependencies:
    [2018-02-15 13:13:00 +0200]     pango is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     fontconfig is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     cairo is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     pixman is needed by cpanel-rrdtool-1.5.5-1.cp1158.x86_64
    [2018-02-15 13:13:00 +0200]     gd >= 2.0.28 is needed by cpanel-perl-524-GD-2.56-1.cp1168.x86_64
    [2018-02-15 13:13:00 +0200]     gd is needed by cpanel-php56-5.6.30-2.cp1164.x86_64
    [2018-02-15 13:13:00 +0200]     libXpm is needed by cpanel-php56-5.6.30-2.cp1164.x86_64
    [2018-02-15 13:13:00 +0200]     libtool-ltdl is needed by cpanel-php56-5.6.30-2.cp1164.x86_64
    [2018-02-15 13:13:00 +0200]     gd is needed by cpanel-webalizer-2.23_08-1.cp1168.x86_64
    [2018-02-15 13:13:00 +0200]     libgd.so.2()(64bit) is needed by cpanel-webalizer-2.23_08-1.cp1168.x86_64
    [2018-02-15 13:13:00 +0200]     libicudata.so.50()(64bit) is needed by dovecot-2.2.33.2-3.cp1162.x86_64
    [2018-02-15 13:13:00 +0200]     libicui18n.so.50()(64bit) is needed by dovecot-2.2.33.2-3.cp1162.x86_64
    [2018-02-15 13:13:00 +0200]     libicuuc.so.50()(64bit) is needed by dovecot-2.2.33.2-3.cp1162.x86_64
    [2018-02-15 13:13:00 +0200]   see RPM Installation Failures - cPanel Knowledge Base - cPanel Documentation for more information
    [2018-02-15 13:13:00 +0200]   The Administrator will be notified to review this output when this script completes
    => Log closed Thu Feb 15 13:13:00 2018
    2018-02-15 13:13:00  982 (DEBUG):   The installation process detected a failed synchronization. The system will reattempt the synchronization with the updatenow.static file...
    2018-02-15 13:13:00  988 (FATAL): The installation process was unable to synchronize cPanel & WHM. Verify that your network can connect to httpupdate.cpanel.net and rerun the installer.
    
    
    Any ideas? Thanks.
     
  2. globaluty

    globaluty Registered

    Joined:
    Feb 15, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bulgaria
    cPanel Access Level:
    Website Owner
    New Reply because can't edit previous...

    When I re-run the installer I got following:

    Code:
    2018-02-15 13:38:52  658 ( INFO): cPanel Layer 1 Installer Starting...
    2018-02-15 13:38:52  659 ( INFO): Warning !!! Warning !!! WARNING !!! Warning !!! Warning
    2018-02-15 13:38:52  660 ( INFO): -------------------------------------------------------
    2018-02-15 13:38:52  661 ( INFO): cPanel requires a fresh, clean server!
    2018-02-15 13:38:52  662 ( INFO): If you serve websites from this server, this installer
    2018-02-15 13:38:52  663 ( INFO): will overwrite all of your configuration files.
    2018-02-15 13:38:52  664 ( INFO): Hit Ctrl+C NOW!
    2018-02-15 13:38:52  665 ( INFO): If this is a new server, please ignore this message.
    2018-02-15 13:38:52  666 ( INFO): -------------------------------------------------------
    2018-02-15 13:38:52  667 ( INFO): Warning !!! Warning !!! WARNING !!! Warning !!! Warning
    2018-02-15 13:38:52  668 ( INFO): Waiting 5 seconds...
    2018-02-15 13:38:52  669 ( INFO): 
    2018-02-15 13:38:52  670 ( INFO): 
    2018-02-15 13:38:57  673 ( INFO): Checking for any control panels...
    2018-02-15 13:38:57  699 ( INFO): Checking for an existing MySQL or MariaDB instance...
    2018-02-15 13:38:57  176 (DEBUG):   Parsing command line arguments.
    2018-02-15 13:38:57  381 ( INFO): Install type: standard
    2018-02-15 13:38:57  190 (DEBUG):   - ssystem [BEGIN]: /usr/sbin/setenforce 0
    2018-02-15 13:38:57  190 (DEBUG):     /usr/sbin/setenforce: SELinux is disabled
    2018-02-15 13:38:57  190 (DEBUG):   - ssystem [END]
    2018-02-15 13:38:57 1417 (DEBUG):   - ssystem [BEGIN]: /usr/bin/rdate -s rdate.cpanel.net
    2018-02-15 13:38:58 1417 (DEBUG):   - ssystem [END]
    2018-02-15 13:38:58 1419 ( INFO): The system set the clock to: Thu Feb 15 13:38:58 2018
    2018-02-15 13:38:58 1429 ( INFO): The system changed the clock by 1 seconds.
    2018-02-15 13:38:58  199 ( INFO): Installing cPanel & WHM LTS version 68.
    2018-02-15 13:38:58  839 (DEBUG):   - ssystem [BEGIN]: /usr/local/cpanel/scripts/checkyum --nokernel --noperl
    open3: exec of /usr/local/cpanel/scripts/checkyum --nokernel --noperl failed at /home/cPanelInstall/selfgz13184/install line 293.Removing /root/installer.lock.
    
     
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,183
    Likes Received:
    1,935
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    It looks like some required packages were not installed during the initial installation of the operating system. Can you let us know how you are installing the OS? Is it via an image provided by your data center/hosting provider?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice