Cloudlinux, cagefs, cpanel moving bug?

Misiek

Well-Known Member
Feb 23, 2004
128
3
168
cPanel Access Level
Root Administrator
Dear all,
Today I noticed a specific bug that caused me a lot of trouble.
I had to move a client from one home to another, after that with cagefs enabled the client got Internal Server Error


[Wed Sep 30 17:15:15 2015] [error] [client 66.249.67.122] SoftException in Application.cpp:604: Could not execute script "/home2/xxxx/forum/download/file.php"
[Wed Sep 30 17:15:15 2015] [error] [client 66.249.67.122] Caused by SystemException in API_Linux.cpp:465: chdir() failed: No such file or directory
[Wed Sep 30 17:15:15 2015] [error] [client 66.249.67.122] Premature end of script headers: file.php
[Wed Sep 30 17:15:15 2015] [error] [client 66.249.67.122] File does not exist: /home2/xxxx/forum/500.shtml

I soved it by doing reenabling of cagefs for this user.
Probably its a bug.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
I had to move a client from one home to another
Hello :)

Could you verify how you moved the account to a different partition?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

Internal case FB-122805 is open to address an issue where when you rearrange an account using WHM, if CageFS is active on the account, you need to remount CageFS. There's currently no time frame on a resolution, but I've linked this thread to the case to note your report.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

To update, this issue was isolated to a bug with Cloud Linux itself (CAG-342). It should work as expected with cPanel version 54 and updated versions of the Cloud Linux packages (via "yum update").

Thank you.