The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CloudLinux error updating PHP package

Discussion in 'CloudLinux' started by garconcn, Jul 14, 2017.

  1. garconcn

    garconcn Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    113
    Likes Received:
    4
    Trophy Points:
    68
    I got this error when run command "yum update ea-php*" on Cloudlinux 7.

    Transaction check error:
    file /usr/include/nghttp2/nghttp2.h from install of ea-libnghttp2-devel-1:1.20.0-1.el7.1.cloudlinux.x86_64 conflicts with file from package libnghttp2-devel-1.7.1-1.el7.x86_64
    file /usr/include/nghttp2/nghttp2ver.h from install of ea-libnghttp2-devel-1:1.20.0-1.el7.1.cloudlinux.x86_64 conflicts with file from package libnghttp2-devel-1.7.1-1.el7.x86_64
    file /usr/lib64/libnghttp2.so from install of ea-libnghttp2-devel-1:1.20.0-1.el7.1.cloudlinux.x86_64 conflicts with file from package libnghttp2-devel-1.7.1-1.el7.x86_64
    file /usr/lib64/pkgconfig/libnghttp2.pc from install of ea-libnghttp2-devel-1:1.20.0-1.el7.1.cloudlinux.x86_64 conflicts with file from package libnghttp2-devel-1.7.1-1.el7.x86_64
     
  2. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    79
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    Hi,

    You might need to remove the following packages:
    libnghttp2 libnghttp2-devel
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,980
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hi @garconcn,

    I moved this post to it's own thread. Do you receive the same error when running the "yum update" command as opposed to just running the "yum update ea-php*" command? If so, could you confirm which repo files exist in your system's /etc/yum.repos.d/ directory?

    Thank you.
     
  4. garconcn

    garconcn Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    113
    Likes Received:
    4
    Trophy Points:
    68
    I run into this error with "yum update ea-php*". I've following repo files:

    -rw-r--r-- 1 root root 328 May 25 08:32 centos-extras.repo
    -rw-r--r-- 1 root root 990 Aug 5 2014 cl-mysql.repo
    -rw-r--r-- 1 root root 657 Jul 28 2016 cloudlinux-ea4.repo
    -rw-r--r-- 1 root root 731 Jul 28 2016 cloudlinux-ea4-testing.repo
    -rw-r--r-- 1 root root 232 May 25 08:32 cloudlinux-imunify360.repo
    -rw-r--r-- 1 root root 2.9K May 25 08:32 cloudlinux.repo
    -rw-r--r-- 1 root root 244 Jul 14 15:26 cPAddons.repo
    -rw------- 1 root root 239 Jun 9 12:18 cpanel-plugins.repo
    -rw-r--r-- 1 root root 119 Jun 20 04:35 kernelcare.repo
    -rw-r--r-- 1 root root 257 Jun 9 12:29 MariaDB100.repo
    -rw-r--r-- 1 root root 118 Jun 12 08:50 r1soft.repo
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,980
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Try running "yum update" on it's own, as YUM may need to update more than just the "ea-" prefixed packages.

    Thank you.
     
  6. garconcn

    garconcn Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    113
    Likes Received:
    4
    Trophy Points:
    68
    Thank you. I don't want to update the kernel because it requires server reboot and force r1soft to do full block scan after reboot. I have kernelcare on the server.

    I tried exclude kernel with command "yum update --exclude=kernel*", but it gave me this error. I also tried "yum update --exclude=kernel* kmod-lve*", it return same error.

    ---> Package kmod-lve.x86_64 1:1.4-55.el7 will be updated
    ---> Package kmod-lve.x86_64 1:1.4-56.el7 will be an update
    --> Processing Dependency: kmod-lve-3.10.0-614.10.2.lve1.4.56.el7.x86_64 >= 1:1.4-56.el7 for package: 1:kmod-lve-1.4-56.el7.x86_64
    ---> Package nscd.x86_64 0:2.17-157.el7_3.4 will be updated
    ---> Package nscd.x86_64 0:2.17-157.el7_3.5 will be an update
    --> Running transaction check
    ---> Package ea-libnghttp2-devel.x86_64 1:1.20.0-1.el7.1.cloudlinux will be installed
    ---> Package kmod-lve-3.10.0-614.10.2.lve1.4.56.el7.x86_64.x86_64 1:1.4-56.el7 will be installed
    --> Processing Dependency: kernel-uname-r = 3.10.0-614.10.2.lve1.4.56.el7.x86_64 for package: 1:kmod-lve-3.10.0-614.10.2.lve1.4.56.el7.x86_64-1.4-56.el7.x86_64
    --> Finished Dependency Resolution
    Error: Package: 1:kmod-lve-3.10.0-614.10.2.lve1.4.56.el7.x86_64-1.4-56.el7.x86_64 (cloudlinux-x86_64-server-7)
    Requires: kernel-uname-r = 3.10.0-614.10.2.lve1.4.56.el7.x86_64
    Installed: 1:kernel-3.10.0-427.18.2.lve1.4.24.el7.x86_64 (@anaconda/7.3)
    kernel-uname-r = 3.10.0-427.18.2.lve1.4.24.el7.x86_64
    Installed: 1:kernel-3.10.0-614.10.2.lve1.4.50.el7.x86_64 (@cloudlinux-x86_64-server-7)
    kernel-uname-r = 3.10.0-614.10.2.lve1.4.50.el7.x86_64
    Installed: 1:kernel-3.10.0-614.10.2.lve1.4.55.el7.x86_64 (@cloudlinux-x86_64-server-7)
    kernel-uname-r = 3.10.0-614.10.2.lve1.4.55.el7.x86_64
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,980
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You could temporarily add the following entries to the "Exclude=" line in /etc/yum.conf:

    Code:
    kmod* kernel* 
    Then, run "yum update" to see if it completes successfully.

    Thank you.
     
  8. garconcn

    garconcn Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    113
    Likes Received:
    4
    Trophy Points:
    68
    Got my original error, guess I have to remove the packages "libnghttp2 libnghttp2-devel" before update.


    Transaction check error:
    file /usr/include/nghttp2/nghttp2.h from install of ea-libnghttp2-devel-1:1.20.0-1.el7.1.cloudlinux.x86_64 conflicts with file from package libnghttp2-devel-1.7.1-1.el7.x86_64
    file /usr/include/nghttp2/nghttp2ver.h from install of ea-libnghttp2-devel-1:1.20.0-1.el7.1.cloudlinux.x86_64 conflicts with file from package libnghttp2-devel-1.7.1-1.el7.x86_64
    file /usr/lib64/libnghttp2.so from install of ea-libnghttp2-devel-1:1.20.0-1.el7.1.cloudlinux.x86_64 conflicts with file from package libnghttp2-devel-1.7.1-1.el7.x86_64
    file /usr/lib64/pkgconfig/libnghttp2.pc from install of ea-libnghttp2-devel-1:1.20.0-1.el7.1.cloudlinux.x86_64 conflicts with file from package libnghttp2-devel-1.7.1-1.el7.x86_64

    Error Summary
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,980
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    It looks like it's just the libnghttp2-devel RPM that's causing the conflict. Try removing just that one and let us know if it allows YUM to update.

    Thank you.
     
  10. garconcn

    garconcn Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    113
    Likes Received:
    4
    Trophy Points:
    68
    Thanks. I works after remove libnghttp2-devel. It seems that cloudlinux use a different name for this package ea-libnghttp2-devel.
     
Loading...

Share This Page