CloudLinux install: unable to start httpd

Mauritz

Well-Known Member
Apr 29, 2015
62
0
6
Johannesburg
cPanel Access Level
Root Administrator
We are unable to install cPanel on a fresh install of CloudLinux 7. The installation itself goes smoothly up until httpd, it attempts to restart but fails again. After the installation is done we get an email sent to us each 5 minutes saying that cPanel is unable to connect to http/https

WHM itself appears to work fine, we're able to log into it and did the basic setup.

Doing a netstat -plant does not show any process binding to either port 80 or 443 and I have tried to do a reset of easyapache but it does not work either.

As a last attempt I formatted the box, installed CloudLinux again and installed cPanel again and during installation the same issue occurs.

I don't quite know which logs or additional info you may need to assist so reply and I will be happy to provide further info.

Thank you!
 

Mauritz

Well-Known Member
Apr 29, 2015
62
0
6
Johannesburg
cPanel Access Level
Root Administrator
So I did a recompile of apache (easyapache 3) within WHM and that appears to have fixed the issue. I am obviously worried that this issue may re-occur later and we would not want that to happen on a production machine, so would still like to troubleshoot the answer if anyone else have any ideas what could have caused this?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
The installation itself goes smoothly up until httpd, it attempts to restart but fails again.
Hello :)

Are you installing cPanel via the steps listed in our documentation, or via an image? Also, could you post the specific output from /var/log/cpanel-install.log that showcases the failure messages?

Thank you.