The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[CloudLinux LVEMAN-543] Paper Lantern errors after WHM 54.0 (build 7) update

Discussion in 'User Experience' started by mythosis, Jan 27, 2016.

  1. mythosis

    mythosis Member

    Joined:
    Oct 29, 2013
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Reseller Owner
    Hi all,

    Just wondering if anyone is having problems with logging in to cpanel accounts after the update.

    It seems that accounts using the theme are throwing errors and users cant log in. I have also tried to access through WHM (list accounts) cPanel and the same error displays.

    Code:
    A fatal error or timeout occurred while processing this directive.
    
    Template::Exception:
        [TYPE]=[undef]
        [INFO]=[Branding::get_available_applications(HASH(0x661c510)) failed: (XID 4zvafb) The system failed to parse the JSON stream from the file “/usr/local/cpanel/base/frontend/paper_lantern//dynamicui.conf” because of an error: garbage after JSON object, at character offset 40053 (before "file=>lverubysel,ski...") at /usr/local/cpanel/Cpanel/JSON.pm line 119, <$_[...]> line 1.
    
    ]
        [TEXT]=[
    
    
    
    
    
    <script type="text/javascript">]
    at cpanel.pl line 1234.
        cpanel::cpanel::cptt_exectag("/usr/local/cpanel/base/frontend/paper_lantern/index.auto.tmpl", 1) called at cpanel.pl line 5214
        cpanel::cpanel::run_standard_mode() called at cpanel.pl line 869
        cpanel::cpanel::script("cpanel::cpanel", "./frontend/paper_lantern/index.html") called at cpanel.pl line 331
    
    
    Is there a why I can force all accounts to use another theme in the meantime.
     
    #1 mythosis, Jan 27, 2016
    Last edited by a moderator: Jan 27, 2016
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might want to try forcing a cPanel update again to see if that's of any help with this.

    x3 has been or is being removed and going back to it out of the question.

    If the forced update doesn't work for you, open a ticket directly to cPanel Technical Support about this, they'll get you sorted out.

    Just to add, I am not seeing that issue on my end, no. Do you have any special customizations or plugins for cPanel of some sort enabled on your server?
     
  3. mythosis

    mythosis Member

    Joined:
    Oct 29, 2013
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Reseller Owner
    update- Edit package manager > Change package to use the x3 theme.

    Manages to log in but no icons are displayed on this.
    - Removed -
    The buttons "reset all interface settings and reveal all boxes do nothing and the page produces 4 JS errors in console.
    upload_2016-1-28_10-11-40.png
     
    #3 mythosis, Jan 27, 2016
    Last edited by a moderator: Jan 28, 2016
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Just for fun, try another browser. Make any difference?
    Did you try forcing an update?
     
  5. mythosis

    mythosis Member

    Joined:
    Oct 29, 2013
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Reseller Owner
    Hmmm we have these,
    upload_2016-1-28_12-47-4.png

    and a newrelic monitoring plugin.

    The only thing that I think would add to the template is maybe the softaculous ??
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I use softaculous too, no errors with it. Not sure if the OneClick SSL is a cPanel interface plugin or not, same with the newrelic thing, can cPanel users access these two from within their cPanel? If yes, the plugin might need an update. The others you list are not cPanel plugins a cPanel user can access, they're accessed via WHM.
     
  7. mythosis

    mythosis Member

    Joined:
    Oct 29, 2013
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Reseller Owner
    Running now ... will keep you posted, Thanks for your help.
     
  8. mythosis

    mythosis Member

    Joined:
    Oct 29, 2013
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Reseller Owner
    Same result for different browsers unfortunately. I have run the force cpanel update from whm and it appears to get stuck at around 88%. It's been sitting there for over an hour however cpu an memory usage have dropped back to normal and I cant see any update processes being run in the process manager. I have tried to login in again ... same result.

    upload_2016-1-28_14-45-34.png

    On cpanel login
    upload_2016-1-28_15-21-4.png

    We have passed this on to our provider T3 support and they are looking at the templates, this may well end up at cPanel support.
     
    Infopro likes this.
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Keep us posted.
     
  10. 1809

    1809 Registered

    Joined:
    Oct 14, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Serbia
    cPanel Access Level:
    Root Administrator
    Hello

    When i try to login in cpanel i get this error,i`m try to update panel to latest version but that was not help.Do you gave any solution?

    Code:
    Template::Exception:
        [TYPE]=[undef]
        [INFO]=[Branding::get_available_applications(HASH(0x6a61e58)) failed: (XID p2gc5r) The system failed to parse the JSON stream from the file “/usr/local/cpanel/base/frontend/paper_lantern//dynamicui.conf” because of an error: garbage after JSON object, at character offset 40053 (before "file=>lverubysel,ski...") at /usr/local/cpanel/Cpanel/JSON.pm line 119, <$_[...]> line 1.
    
    ]
        [TEXT]=[
    
    
    
    
    
    <script type="text/javascript">]
    at cpanel.pl line 1234.
        cpanel::cpanel::cptt_exectag("/usr/local/cpanel/base/frontend/paper_lantern/index.auto.tmpl", 1) called at cpanel.pl line 5214
        cpanel::cpanel::run_standard_mode() called at cpanel.pl line 869
        cpanel::cpanel::script("cpanel::cpanel", "./frontend/paper_lantern/index.html") called at cpanel.pl line 331
    
     
  11. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    @1809, I've merged your thread into this one as you're seeing the same error described here.
     
  12. kjg

    kjg Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Got the same error

    Changed theme for the package that the account uses back to x3 and it worked.

    Found a number of accounts having the same issue on different servers. Mostly accounts having x3mail. Changing them to x3 solved it.

    Hope this helps

    edit: A lot of the accounts having packages where it said paper_lantern, actuall y had x3mail still and that did not work.

    edit2: Changing all accounts can be done via WHM Home »Multi Account Functions »Modify/Upgrade Multiple Accounts
     
    #12 kjg, Jan 28, 2016
    Last edited: Jan 28, 2016
  13. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I'm not sure this applies here, but if you've got custom options in your Paper Lantern (that work fine in x3), they might need a small change made to them as mentioned at top of this page:
    Guide to cPanel Interface Customization - Software Development Kit - cPanel Documentation

    No clue if thats helpful or not.
     
  14. 1809

    1809 Registered

    Joined:
    Oct 14, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Serbia
    cPanel Access Level:
    Root Administrator
    changing theme to X3 do not help too much in my case
    - Removed -
     
    #14 1809, Jan 28, 2016
    Last edited by a moderator: Jan 28, 2016
  15. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Please attach images to your posts. I've seen the image showing x3 with no icons.

    What version of cPanel is your server running on?
     
  16. 1809

    1809 Registered

    Joined:
    Oct 14, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Serbia
    cPanel Access Level:
    Root Administrator
    My version is 11.54.0.8
     

    Attached Files:

  17. mythosis

    mythosis Member

    Joined:
    Oct 29, 2013
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Reseller Owner
    A Response back from cPanel, sent from my provider. I currently still have no access so I'm just checking to see if it has been implemented.

    cPanel have acknowledged that this is a known issue, and they are tracking the bug under ID "CPANEL-3875" which can be tracked via Change Logs - Documentation - cPanel Documentation.

    The recommended workaround has been implemented and the Paper Lantern theme now appears to be working correctly.

    WORKAROUND DETAILS:
    Comment out the below two lines from /usr/local/cpanel/base/frontend/paper_lantern/dynamicui.conf:
    #file=>lverubysel,skipobj=>1 # this line is modified by /usr/share/l.v.e-manager/cpanel/utils/dynamicuictl.py
    #file=>lvepythonsel,skipobj=>1 # this line is modified by /usr/share/l.v.e-manager/cpanel/utils/dynamicuictl.py
     
    Infopro likes this.
  18. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Excellent, thanks for posting back with the update to this.
     
  19. mythosis

    mythosis Member

    Joined:
    Oct 29, 2013
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Reseller Owner
    Working Update: I just nano'd the file as the server still had the error. I saw that there were 4 lines at the end of the file the first two had been commented out by my provider but it seems that they had been added again (presumably by the dynamicuictl.py) script. I just commented out the extra two and now it seems to be letting me log in.

    I would imagine I would have to go in and add more comments as time passes (if extra lines are added) but for now its something I can work with.

    upload_2016-1-29_9-13-36.png
     
  20. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Please update your cloudlinux install to get lvemanager-1.0-9.17 or later
    Beta: LVEManager updated
    The cloudlinux case that resolves this problem is LVEMAN-543
     

Share This Page