Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Clustered secondary Names Server IP updated but not propagating

Discussion in 'Bind/DNS/Nameserver' started by Webdew, May 20, 2018.

  1. Webdew

    Webdew Member

    Joined:
    Jun 18, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I have had the static IP of an offsite Name Server mirror updated (cPanel DNSONLY Installation). It is one of four DNS servers - I'll call it NS3. i have checked other forum posts but have fond nothing clearly stating how this _should_ be fixed.

    Right now external queries still show this NS entry as the old IP and therefore fail. It has been a week since the IP was changed. It is not obvious at all what needs to happen to get this resolving.

    I have previously performed the following.

    • the GLUE entry for the NS3.domain.com assigned to this server has had the IP updated in the registrar.
    • confirmed the NS3 only server has the right IP assigned locally.
    • confirm that in the NS3 server Server Configuration > Basic Webhost Setup the IP is set and showing correctly
    • If I go to Server Configuration > Basic Webhost Setup and change the A dress Records for the server - in any other NS in the cluster - they seem to save but checking later they revert.
    • the Zone for the domain pointing to this cluster has had the record for the NS3 entry updated. I have even removed it for 24 hours and recreated it. It does not revert it just seems not to be used.
    • I removed and rejoined the NS3 server to the cluster - using a new Key pair to authenticate. (this would not rejoin for the first 24 hours I assume due to the GLU records TTL updating?) It is seen by the other servers in the cluster and changes to zones show updates propagate changes. A manual DNS Zone sync from others in the cluster shows that NS3 is getting the updates.

    External queries for the Cluster Name Server continue to resolve the old IP.

    I can't figure out why the NS Servers won't hold the update made in Basic Webhost Setup or how externals are getting the old IP considering the Glue and the zone on the servers show the new IP. Where is it coming from and how can I change or update it.
     
  2. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    1,350
    Likes Received:
    90
    Trophy Points:
    103
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Webdew

    It sounds as if somewhere in the cluster the NS IP isn't being updated properly. nameservers are ns.domain.tld on any of the servers do you have ns3 added to the domain.tld zone record as well as it's own separate ns record? If so are any listing the IP address incorrectly?

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice