Cmd Service Check Raw Output: Spamd is not running

nicefrid

Member
Aug 18, 2010
10
0
51
Sir..

Problem: Cmd Service Check Raw Output: Spamd is not running

I am getting this email every 5minutes. it was very critical issue?

I have studied in forum to solve this problem, so i do this.. but i get result as Unable to locate working spamd! Please check your installation.

Any one see the status and give how to do solve this problem.
Below status is when upgrade..

Code:
[email protected] [~]# /scripts/upcp --force
Running Futex Check/Fix......Done
Updating /scripts...
Sync Source: http://httpupdate.cpanel.net/RELEASE-x86_64/Cpanel
Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE-x86_64/Cpanel/.cpanelsync.lock (0)[email protected]
Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE-x86_64/Cpanel/.cpanelsync.bz2 (1)[email protected]%......Done
Sync Source: http://httpupdate.cpanel.net/RELEASE-x86_64/scripts
Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE-x86_64/scripts/.cpanelsync.lock (0)[email protected]
Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE-x86_64/scripts/.cpanelsync.bz2 (1)[email protected]%......Done
...Done
Checking for main ip changes......Done
Checking mySQL to ensure we can connect......Done
Sending usage data (if enabled)...Anonymous usage data accepted [175].
...Done
Validating cPanel system users...Homedir: /var/cpanel/userhomes/cpanel
...Done
Updating email whitelists......Done
Checking and Repairing System Package Setup......Done
Running Platform Specific Optimizations......Done
Checking and Repairing Nameserver Config......Done
Setting up ip startup......Done
Configuring editors......Done
Creating symlinks for common binaries...Unable to locate working spamc! Please check your installation.
Unable to locate working spamd! Please check your installation.
Unable to locate working spamassassin! Please check your installation.
...Done
Setting Clock...rdate: rdate: could not set system time: Operation not permitted
...Done
Running Env Auto Repair...quota test: check passed (the repquota signal was 0 [ok])
Requesting script ... Done
Auto Repair is running...Running Auto Repair routines
Finished running Auto Repair routines
...Auto Repair is done.
...Done
Running Cleanups...Found hostname to be xxx.domain.com, which resolves to xxx.xxx.xxx.xxx
Hostname Virtual Host is already setup
...Done
Updating services & databases...PHP version file is up to date
Restarting spamd
Config File Count: 0
Spamassassin Update Failed, reinstalling!
Method: Perl Expect
Fetching CPAN mirrors...Fetching http://httpupdate.cpanel.net/pub/cpanmirror/MIRRORED.BY.bz2 (0)[email protected]%......Done
Done
Fetching CPAN timestamp...Fetching http://httpupdate.cpanel.net/pub/CPAN/MIRRORING.FROM (0)[email protected]%......Done
Done
 

JawadArshad

Well-Known Member
PartnerNOC
Apr 8, 2008
459
7
68
PK
cPanel Access Level
DataCenter Provider
Sir..

Problem: Cmd Service Check Raw Output: Spamd is not running

I am getting this email every 5minutes. it was very critical issue?

I have studied in forum to solve this problem, so i do this.. but i get result as Unable to locate working spamd! Please check your installation.

Any one see the status and give how to do solve this problem.
Below status is when upgrade..

Code:
[email protected] [~]# /scripts/upcp --force
Running Futex Check/Fix......Done
Updating /scripts...
Sync Source: http://httpupdate.cpanel.net/RELEASE-x86_64/Cpanel
Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE-x86_64/Cpanel/.cpanelsync.lock (0)[email protected]
Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE-x86_64/Cpanel/.cpanelsync.bz2 (1)[email protected]%......Done
Sync Source: http://httpupdate.cpanel.net/RELEASE-x86_64/scripts
Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE-x86_64/scripts/.cpanelsync.lock (0)[email protected]
Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE-x86_64/scripts/.cpanelsync.bz2 (1)[email protected]%......Done
...Done
Checking for main ip changes......Done
Checking mySQL to ensure we can connect......Done
Sending usage data (if enabled)...Anonymous usage data accepted [175].
...Done
Validating cPanel system users...Homedir: /var/cpanel/userhomes/cpanel
...Done
Updating email whitelists......Done
Checking and Repairing System Package Setup......Done
Running Platform Specific Optimizations......Done
Checking and Repairing Nameserver Config......Done
Setting up ip startup......Done
Configuring editors......Done
Creating symlinks for common binaries...Unable to locate working spamc! Please check your installation.
Unable to locate working spamd! Please check your installation.
Unable to locate working spamassassin! Please check your installation.
...Done
Setting Clock...rdate: rdate: could not set system time: Operation not permitted
...Done
Running Env Auto Repair...quota test: check passed (the repquota signal was 0 [ok])
Requesting script ... Done
Auto Repair is running...Running Auto Repair routines
Finished running Auto Repair routines
...Auto Repair is done.
...Done
Running Cleanups...Found hostname to be xxx.domain.com, which resolves to xxx.xxx.xxx.xxx
Hostname Virtual Host is already setup
...Done
Updating services & databases...PHP version file is up to date
Restarting spamd
Config File Count: 0
Spamassassin Update Failed, reinstalling!
Method: Perl Expect
Fetching CPAN mirrors...Fetching http://httpupdate.cpanel.net/pub/cpanmirror/MIRRORED.BY.bz2 (0)[email protected]%......Done
Done
Fetching CPAN timestamp...Fetching http://httpupdate.cpanel.net/pub/CPAN/MIRRORING.FROM (0)[email protected]%......Done
Done
Do you have spamassassin enabled in "WHM >> Tweak Settings as well as in "WHM >> Service Manager". After ensuring this try /scripts/fixspamassassinfailedupdate as root. See if it works. You can always open a ticket with cPanel support regarding this as well.
 

nicefrid

Member
Aug 18, 2010
10
0
51
Do you have spamassassin enabled in "WHM >> Tweak Settings as well as in "WHM >> Service Manager". After ensuring this try /scripts/fixspamassassinfailedupdate as root. See if it works. You can always open a ticket with cPanel support regarding this as well.

Sir, I like to learn & do troubleshooting myself.. so what i dont submit ticket. Because i like to handle cpanel. so sorry. if compulsory need then i will submit ticket.

Already enable in Tweak settings.. but in service manager i am not able to see as spamassassin, i mean there is no.

In tweak settings i have see another settings also, but i dont know i need to enable this?
See below line.
SpamAssassin Spam Box delivery for messages marked as spam (user configurable)

I need to enable this option?
 

JawadArshad

Well-Known Member
PartnerNOC
Apr 8, 2008
459
7
68
PK
cPanel Access Level
DataCenter Provider
Sir, I like to learn & do troubleshooting myself.. so what i dont submit ticket. Because i like to handle cpanel. so sorry. if compulsory need then i will submit ticket.

Already enable in Tweak settings.. but in service manager i am not able to see as spamassassin, i mean there is no.
Do you have the option "spamd SpamAssassin Server (if you choose to disable this, you should disable SpamAssasin in tweak settings as well)" in "Service Manager" enabled. If not, you need to enable it.
Also, did you run the script that I pointed to in my previous reply.

In tweak settings i have see another settings also, but i dont know i need to enable this?
See below line.
SpamAssassin Spam Box delivery for messages marked as spam (user configurable)

I need to enable this option?
This should not cause a failed spamassassin update.
 

nicefrid

Member
Aug 18, 2010
10
0
51
Sir, I have run that script now i am getting mail as per hour or 2 hours one mail as failed.

some as good, but not feel well.

i am not able to see that settings in service manager. I need to install any scripts? or need to enable any where.. tweak settings has been enabled, but no option in service manager, pls guide me.

* Always cpanel hanging because of getting more resources to mysql, but not more traffic for sites... what can i do?
 

JawadArshad

Well-Known Member
PartnerNOC
Apr 8, 2008
459
7
68
PK
cPanel Access Level
DataCenter Provider
It is difficult to provide accurate troubleshooting info on such vague information. The quickest and best solution would be to open a ticket with your host's support and/or open a ticket with cPanel support. In my experience, cPanel support has among the quickest response times.

Sir, I have run that script now i am getting mail as per hour or 2 hours one mail as failed.

some as good, but not feel well.

i am not able to see that settings in service manager. I need to install any scripts? or need to enable any where.. tweak settings has been enabled, but no option in service manager, pls guide me.

* Always cpanel hanging because of getting more resources to mysql, but not more traffic for sites... what can i do?