The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CNAME record not showing up in Lookup

Discussion in 'General Discussion' started by jason_85, Mar 29, 2011.

  1. jason_85

    jason_85 Member

    Joined:
    Feb 8, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Hi everyone,
    I am trying to park my domain using google adsense, and have good reasons for using CNAME/A record option rather than the recommended Nameserver settings (see https://www.google.com/adsense/support/bin/answer.py?answer=76049). Here are my records for the domain "techfree.info":

    Code:
    techfree.info.	14400	IN	A	216.239.32.21
    techfree.info.	14400	IN	A	216.239.34.21
    techfree.info.	14400	IN	A	216.239.36.21
    techfree.info.	14400	IN	A	216.239.38.21
    www.techfree.info.	14400	IN	CNAME	pub-9169442869980017.afd.ghs.google.com
    When I do a lookup using KLOTH.NET - NSLOOKUP - DNS Look up - Find IP Address it only detects the A records, not the CNAME record. Also, my domain with google is still "pending" after 48 hours, leading me to believe that maybe there is something wrong with the settings I've used.

    Any help or guidance would be much appreciated.

    Jason
     
  2. MattLee

    MattLee BANNED

    Joined:
    Aug 26, 2009
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    I am showing that the CNAME is being properly returned when performing a lookup for this domain.

    root@macmini [~]# dig www.techfree.info +short
    pub-9169442869980017.afd.ghs.google.com.
    ghs.l.google.com.
    74.125.47.121

    and

    ---------------
    here is the nslookup result for www.techfree.info from server localhost, querytype=ANY :
    DNS server handling your query: localhost
    DNS server's address: 127.0.0.1#53

    Non-authoritative answer:
    www.techfree.info canonical name = pub-9169442869980017.afd.ghs.google.com.
    ---------------
     
  3. jason_85

    jason_85 Member

    Joined:
    Feb 8, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Oh right; my mistake was omitting the 'www" when searching for the CNAME record. One more question; on the google adsense for domains instructions it says that the CNAME record should be set for an alias/Hostname "www". As this is an invalid input in cPanel I've used "www.techfree.info"; is this correct?
     
  4. MattLee

    MattLee BANNED

    Joined:
    Aug 26, 2009
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    That should work. You can choose to specify the domain after the www in the DNS record.
     
Loading...

Share This Page