Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

(code: 451, response: Temporary local problem - please try later)

Discussion in 'E-mail Discussion' started by mehdy007, Jan 12, 2010.

Thread Status:
Not open for further replies.
  1. mehdy007

    mehdy007 Registered

    Joined:
    Jan 12, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    51
    Dear all

    please help me!

    i have host on server and this configure for mail :

    Verifying MX Records and Setting up Databases...Reconfiguring Mail Routing:

    * BACKUP MAIL EXCHANGER: This server will serve as a backup mail exchanger for xxx.com' s mail.:
    This configuration has been manually selected.

    ...Done

    but when i want send mail i see this error :
    There was an error sending your message: Failed to add recipient: xxx@xxx.com [SMTP: Invalid response code received from server (code: 451, response: Temporary local problem - please try later)]



    how can i fix it?
     
  2. InstaCarma_Tech

    InstaCarma_Tech Well-Known Member

    Joined:
    Apr 22, 2009
    Messages:
    228
    Likes Received:
    1
    Trophy Points:
    68
    I am having a little difficulty in understanding your email set up. Check whether the domain is present in /etc/localdomains.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. nasir5

    nasir5 Registered

    Joined:
    Apr 19, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    There are so many reasons for this issue to happen. Same issue appeared to one of my client and I found that the domain was not in /etc/localdomains which the MX was pointing locally.
     
  4. aymanoscar

    aymanoscar Registered

    Joined:
    Jan 10, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    126
    I added the domain name to /etc/localdomains and it has been worked
    thanks for your support
     
  5. KurtKraut

    KurtKraut Registered

    Joined:
    Jan 26, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    51
    This problem also happened to me on WHM 11.28.64 and the workaround provided above fixed the problem. Is this a cPanel bug?
     
  6. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    5
    Trophy Points:
    68
    cPanel Access Level:
    Root Administrator
    Hello,

    It is not a cPanel bug. If your domain has MX on the same server, it should be in /etc/localdomains. If the domain is having a remote MX, it should be placed in /etc/remotedomains.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. cPanelJared

    cPanelJared Technical Analyst

    Joined:
    Feb 25, 2010
    Messages:
    1,835
    Likes Received:
    20
    Trophy Points:
    143
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Make sure that the e-mail routing setting for the domain is correct. In the WebHost Manager, click Main >> DNS Functions >> Edit DNS Zone and select the domain in question. At the bottom of the page will be a setting labeled "Email Routing for". Automatically Detect Configuration is the default, but you may need to select Local Mail Exchanger.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. allzhat

    allzhat Registered

    Joined:
    Dec 28, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Root Administrator
    I also face that problem this day

    and I simply "restart" the MX record from automatic to local, and reverting it back, and voila the case is closed :D
     
Loading...
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice