code 4608 on update from 11.34.1.13 to 11.36.0.20

Xoles

Member
Apr 2, 2013
8
0
51
cPanel Access Level
Root Administrator
Since 11.36 I'm having this error on a 2.6.18-308.11.1.el5

Code:
[20130402.010332] 0% complete [20130402.010332] Detected cron=0 (env var CPANEL_IS_CRON was present before this process started.) [20130402.010332] 1% complete ----------------------------------------------------------------------------------------------------
=> Log opened from /scripts/upcp at Tue Apr  2 01:03:32 2013
[20130402.010332]   Detected cron=0 (env var CPANEL_IS_CRON was present before this process started.)
=> Log closed Tue Apr  2 01:03:32 2013
[20130402.010332]   Running Standardized hooks
[20130402.010332]   mtime on upcp is 1355811705 (Tue Dec 18 00:21:45 2012)
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow at Tue Apr  2 01:03:32 2013
[20130402.010332]   Detected version '11.34.1.13' from version file.
[20130402.010332]   Target version set to '11.36.0.20'
[20130402.010332]   Switching to 11.36.0.20 to determine if we can reach that version without failure.
[20130402.010332]   Retrieving /cpanelsync/11.36.0.20/cpanel/scripts/updatenow.static.bz2
[20130402.010334]   Using mirror: 70.87.220.252
=> Log closed Tue Apr  2 01:03:34 2013
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow.static at Tue Apr  2 01:03:34 2013
[20130402.010334]   Detected version '11.34.1.13' from version file.
[20130402.010334]   Target version set to '11.36.0.20'
[20130402.010334]   Checking license
[20130402.010334]   License file check complete
[20130402.010334]   Checking that the RPM DB is OK...
[20130402.010334]   glibc-2.5-81.el5_8.4
[20130402.010334]   glibc-2.5-81.el5_8.4
[20130402.010334]   OK: RPM DB is responding to queries
[20130402.010334]   Testing if rpm_is_working RPM is installed
[20130402.010334]   package rpm_is_working is not installed
[20130402.010334]   Testing if it's possible to install a simple RPM
[20130402.010334]   Preparing...                ##################################################
[20130402.010334]   rpm_is_working              ##################################################
[20130402.010334]   Switching to version '11.36.0.20' of updatenow to perform sync.
[20130402.010336]   Loaded plugins: katello, product-id, security, subscription-manager
[20130402.010336]   Updating certificate-based repositories.
[20130402.010336]   Setting up Install Process
[20130402.010336]   No package glib available.
[20130402.010336]   Nothing to do
[20130402.010336]   Prelinking shared libraries and binaries: /usr/sbin/prelink -av -mR
[20130402.010339] E Sysup: Needed system RPMs were not installed: glib
[20130402.010339] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
[20130402.010339]   The Administrator will be notified to review this output when this script completes
[20130402.010339] E Detected events which require user notification during updatenow. Will send iContact the log
=> Log closed Tue Apr  2 01:03:39 2013
[20130402.010339] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1364886212.log` failed, exited with code 4608
=> Log closed Tue Apr  2 01:03:39 2013



/etc/yum.conf
[main]
exclude=apache* bind-chroot courier* dovecot* exim* filesystem httpd* mod_ssl* mydns* mysql* nsd* perl* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*


 [~]# yum search glib
Loaded plugins: katello, product-id, security, subscription-manager
Updating certificate-based repositories.
=============================================================================== Matched: glib ================================================================================
NetworkManager-glib.i386 : Libraries for adding NetworkManager support to applications that use glib.
NetworkManager-glib.x86_64 : Libraries for adding NetworkManager support to applications that use glib.
avahi-glib.i386 : Glib libraries for avahi
avahi-glib.x86_64 : Glib libraries for avahi
dbus-glib.i386 : GLib bindings for D-Bus
dbus-glib.x86_64 : GLib bindings for D-Bus
dbus-glib-devel.x86_64 : Libraries and headers for the D-Bus GLib bindings
glib2.i386 : A library of handy utility functions
glib2.x86_64 : A library of handy utility functions
glib2-devel.i386 : The GIMP ToolKit (GTK+) and GIMP Drawing Kit (GDK) support library
glib2-devel.x86_64 : The GIMP ToolKit (GTK+) and GIMP Drawing Kit (GDK) support library
glibc.i686 : The GNU libc libraries.
glibc.x86_64 : The GNU libc libraries.
glibc-common.x86_64 : Common binaries and locale data for glibc
glibc-devel.i386 : Object files for development using standard C libraries.
glibc-devel.x86_64 : Object files for development using standard C libraries.
glibc-headers.x86_64 : Header files for development using standard C libraries.
gtk-doc.noarch : API documentation generation tool for GTK+ and GNOME
kernel-headers.x86_64 : Header files for the Linux kernel for use by glibc
libsoup.i386 : Soup, an HTTP library implementation
libsoup.x86_64 : Soup, an HTTP library implementation
nss_db.i386 : An NSS library for the Berkeley DB.
nss_db.x86_64 : An NSS library for the Berkeley DB.
yp-tools.x86_64 : NIS (or YP) client programs.
Any Idea?
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
23
143
Houston, TX
cPanel Access Level
Root Administrator
The problem is in the output you pasted:

Code:
[20130402.010339] E Sysup: Needed system RPMs were not installed: glib
Make sure that glib is installed and that there are no discrepancies in the RPM package. To check for discrepancies, use this:

Code:
# rpm -V glib
If there are any discrepancies, you can reinstall it using yum. If it is not installed at all, you can install it using yum.

glib is part of the operating system, not part of cPanel, so you may need to ask your data center for help making sure it is installed and intact. glib is actually a core part of the operating system, so this problem is bigger than just a cPanel update, and it is not caused by cPanel.