The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Code Editor makes Mozilla Aurora and Firefox crash on my Windows 7 PC

Discussion in 'General Discussion' started by C.Schofield, Jul 20, 2012.

  1. C.Schofield

    C.Schofield Registered

    Joined:
    Jul 20, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Reseller Owner
    Hi,

    I'm posting this just to see if anybody else is having the same problem as me or whether it is just my machine.

    Basically, for the last week or so I have been experiencing difficulties with cpanel code editor using Mozilla Firefox and Aurora. When I start typing in the code editor, I can write maybe a line or two, but anything more and the program crashes and asks to be restarted so I am struggling to get much work done lately.

    The cpanel is up to date, and the browsers haven't been updated for a few weeks so I can't work out why it just started crashing all of a sudden. I have tried to use the latest Safari and Internet Explorer 9, but they seem to struggle to move to a new line when I press enter.

    Does anybody know if this is a cpanel issue, my computers issue or my hosts issue?

    Cheers
     
  2. JayFromEpic

    JayFromEpic Well-Known Member

    Joined:
    Apr 2, 2011
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Scottsdale, AZ
    cPanel Access Level:
    Root Administrator
    That sounds like an actual issue on your computer. I would double check and make sure things like Flash and java are up to date. If that doesn't work, run windows update. If that still doesn't work, you could always do what I do, just backup important data and wipe the PC and reload the OS.
     
  3. CitizenK

    CitizenK Well-Known Member

    Joined:
    Jun 5, 2012
    Messages:
    64
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    On The Road
    cPanel Access Level:
    Root Administrator
    Hello,

    This sounds like a possible conflict with an extention installed in your firefox profile. I would recommend first starting firefox in private browsing mode and see if you still have your issue. Following this guide may also helo you solve a firefox related problem. Standard diagnostic - Firefox - MozillaZine Knowledge Base

    The second thing that would be helpful to know is do other computers have the same problem when using the code editor installed on your server. If other computers can use the code editor, then its most likely a problem with that one computer. However if the issue exists on a few computers, you likely have an issue with your server.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I don't believe it's likely a Firefox extension if Mozilla Aurora isn't using the same extension set. Also, since the user also reported this:

    If the Code Editor is having this much trouble on your account and you do not have access to the server backend to see if there are any errors generating in /usr/local/cpanel/logs/error_log location, please ask your hosting provider to check the logs.

    You might also want to add Firebug to Firefox to see if you can obtain any errors when launching the Code Editor.

    I do agree that trying another computer to see the results is a good idea, though. If you have access to one, please try to see if the same thing is happening on it for File Manager's Code Editor.

    Finally, is this the same page you are trying to edit each time or different pages? If it's just one page, it might be something about that specific page that's the issue.
     
Loading...

Share This Page