The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

comcast.net rDNS issues when rDNS is configured

Discussion in 'E-mail Discussions' started by parrotalert, Dec 11, 2012.

  1. parrotalert

    parrotalert Registered

    Joined:
    Dec 11, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I've been getting 554 errors from comcast.net via email sent via my site: /http://www.parrotalert.com and via the server level mail (lin01.webhosting365.com). It came to my attention when users started contacting me about having email activation issues. I get emails from them, but all new emails and replies bounce when sent to comcast.net.
    It's only affecting comcast.com as i've been trapping all bounces that come back (no user here etc, 554 etc)

    Error:
    Comcast requires that all mail servers must have a PTR record with a valid Reverse DNS entry. Currently your mail server does not fill that requirement. For more information, refer to: /http://postmaster.comcast.net/smtp-error-codes.php#554]

    I have rDNS's set up.

    The server i'm running on, i look after:

    Address: lin01.webhosting365.com
    IP: 83.170.103.16

    There is a rDNS set up (using host or various web checkers)

    The output from host ip, host domain:
    16.103.170.83.in-addr.arpa domain name pointer lin01.webhosting365.com.

    lin01.webhosting365.com has address 83.170.103.16

    mxtoolbox reports ok:

    /http://mxtoolbox.com/SuperTool.aspx?action=smtp%3alin01.webhosting365.com


    If i telnet from the server: 83.170.103.16

    root@lin01 [~]# telnet mx1.comcast.net 25
    Trying 2001:558:fe14:70::22...
    Connected to mx1.comcast.net.
    Escape character is '^]'.
    554 imta07.westchester.pa.mail.comcast.net comcast 2a02:2498:1:3c1:225:90ff:fe75:2a6a Comcast requires that all mail servers must have a PTR record with a valid Reverse DNS entry. Currently your mail server does not fill that requirement. For more information, refer to: /http://postmaster.comcast.net/smtp-error-codes.php#554
    Connection closed by foreign host.

    If i send email via webhosting365.com, i also get the same bounced error.

    Also, i've configured via WHM parrotalert.com to having it's mail send via it's site IP: 83.170.103.140

    The output from host ip, host domain:
    140.103.170.83.in-addr.arpa domain name pointer mail.parrotalert.com.

    mail.parrotalert.com is an alias for parrotalert.com.
    parrotalert.com has address 83.170.103.140
    parrotalert.com mail is handled by 0 parrotalert.com.

    As you can see, there is also a rDNS set up for the server domain/ip and site domain/ip.

    I get the same bounce error message for both and can't figure out why?

    parrotalert.com has the following in the DNS zone:

    parrotalert.com. 86400 IN NS ns1.webhosting365.com.
    parrotalert.com. 86400 IN NS ns2.webhosting365.com.
    parrotalert.com. 14400 IN A 83.170.103.140
    parrotalert.com. 14400 IN MX 0 parrotalert.com.
    mail 14400 IN CNAME parrotalert.com.
    ns1 14400 IN A 83.170.103.16
    ns1 14400 IN A 83.170.103.127

    plus the server company added the rDNS for 83.170.103.140 -> mail.parrotalert.com months ago.

    also, the main server DNS zone:

    webhosting365.com. 86400 IN NS ns1.webhosting365.com.
    webhosting365.com. 86400 IN NS ns2.webhosting365.com.
    webhosting365.com. 14400 IN A 83.170.103.16
    webhosting365.com. 14400 IN MX 0 webhosting365.com.
    ns1 14400 IN A 83.170.103.16
    ns1 14400 IN A 83.170.103.127
    lin01 14400 IN A 83.170.103.16

    plus the server company added the rDNS for 83.170.103.16 -> lin01.webhosting365.com months ago.

    also, setup as per WHM config for /etc/mailips and /etc/mailhelo

    /etc/mailips:

    parrotalert.com: 83.170.103.140
    mail.parrotalert.com: 83.170.103.140
    *: 83.170.103.16

    /etc/mailhelo:

    parrotalert.com: parrotalert.com
    mail.parrotalert.com: parrotalert.com
    *: lin01.webhosting365.com


    AOL and others used to bounce until this was set, recently comcast.net started sending 554 for all emails sent via lin01.webhosting365.com (83.170.103.16) and parrotalert.com (83.170.103.140).
    It also appears impossible to contact them regarding why when i have rDNS setup.

    any ideas?
     
  2. parrotalert

    parrotalert Registered

    Joined:
    Dec 11, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I was able to speak to comcast.net who investigated.

    It appears all ipv4 rDNS were ok.

    However, even though my server company said they aren't supporting ipv6 until next year, i'd been assigned an ipv6 address which comcast tried to resolve against. All ip's at the server level are ipv4, it has something to do with how the outside world saw the server.

    They recommended that i get my server company to add a parallel rDNS for ivp6 or eliminate the use of ipv6 identification completely.

    I had a little play and found this actually solved the problem:

    File: /etc/sysconfig/named
    Added:

    OPTIONS="-4"

    File: /etc/sysctl.conf
    Added:

    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.default.disable_ipv6 = 1

    Rebooted.

    Now when telneting to:
    telnet mx2.comcast.net 25
    Trying 76.96.40.147...
    Connected to mx2.comcast.net.
    Escape character is '^]'.
    220 imta30.emeryville.ca.mail.comcast.net comcast ESMTP server ready

    mx1.comcast.net is ivp6 only, mx2.comcast.net supports both, that's what is connects to via ipv4, as ipv6 was enabled at the kernel, it tried to resolve to my external ipv6 address i wan't aware i had. disabling ipv6 at the kernel and disabling lookups via named (DNS), solved this.

    Emails so far haven't bounced and appear to have gone through.
     
Loading...

Share This Page