SOLVED command-line file transport

ispweb

Member
PartnerNOC
Aug 22, 2014
16
3
53
cPanel Access Level
DataCenter Provider
I was testing if it's possible to create a backup from command-line, that works with:

/scripts/pkgacct username

after that is was trying to get that file uploaded to the backup destination, just like it's found on : https://support.cpanel.net/hc/en-us...ransport-Backups-to-Remote-Backup-Destination

/scripts/cpbackup_transport_file --transport $ID -- upload /created/backup/file/location

When i look at the /usr/local/cpanel/logs/cpbackup_transporter.log

Nothing happens, and i dont see the file on the remote server.

Please help!
 

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
1,046
111
118
Houston, TX
cPanel Access Level
Root Administrator
Hello! There could be a wide variety of issues causing this problem. To confirm, when you put "/created/backup/file/location" you are putting the full path to the backup file you're transporting on the source server, correct? The transport ID tells the command where to send the backup and the file path tells the command where the file is on the source server. If you are already doing this, can you open a ticket using the link in my signature? Having access would allow us to investigate more quickly.
 

ispweb

Member
PartnerNOC
Aug 22, 2014
16
3
53
cPanel Access Level
DataCenter Provider
Yes, /created/backup/file/location is the file, the name was as example, and the $ID i replaced yu the correct ID.

When i do that i get the following text on command-line:

Attempting transport of '/backup/2021-11-04/accounts/xxxxxxx.tar.gz' using transport ID 'xxxxxxxxxxxxxxx'.
Instantiating Object
info [cpbackup_transport_file] Starting a "do_the_dew" operation on the "xxxxxxxxxxxxx (SFTP)" destination ID "xxxxxxxxxxxxxxx".
info [cpbackup_transport_file] Base path for destination is xxxxxxxxxxx

So i looks al that it's going to upload, but don't see files om remote site, and transferlog is also not changed.

The automatic backup works without problems, so the transport destination works.
 

ispweb

Member
PartnerNOC
Aug 22, 2014
16
3
53
cPanel Access Level
DataCenter Provider
I tested it on an other cpanel server there it's working fine.

Attempting transport of '/home/xxxxxxxxxxxxx.tar.gz' using transport ID 'xxxxxxxxxxxxx''.
Instantiating Object
info [cpbackup_transport_file] Starting a "do_the_dew" operation on the "xxxxxxxxxxxx" destination ID "xxxxxxxxxxxxxxx".
info [cpbackup_transport_file] Base path for destination is xxxxxxxxxxxx
Validating destination path xxxxxxxxxxx/manual_backup/
Making Path xxxxxxxxxxx/manual_backup/
Path creation successful
Uploading account backup /home/xxxxxxxxxxx.tar.gz to xxxxxxxxxx/manual_backup/xxxxxxxxxx.tar.gz (from manual_backup/xxxxxxxxxxx.tar.gz)
Attempting to upload /home/xxxxxxxxxx.tar.gz to xxxxxxxxxx/manual_backup/xxxxxxxxxxx.tar.gz for destination: xxxxxxxxxxxxx
info [cpbackup_transport_file] Upload attempt #1 starting for /home/xxxxxxxxxxxx.tar.gz to xxxxxxxxx/manual_backup/xxxxxxxxx.tar.gz for destination: xxxxxxxxxx
Successful transfer of /home/xxxxxxxxxx.tar.gz to xxxxxxxxx/manual_backup/xxxxxxxxx.tar.gz for destination xxxxxxxxxx

The server that's working is on v98.0.10 and the not working on is v100.0.1 didn't do a test on a other cpanel with v100