The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

command to disable suexec in shell?(i can't access whm)

Discussion in 'General Discussion' started by gundamz, Jun 10, 2004.

  1. gundamz

    gundamz Well-Known Member

    Joined:
    Mar 27, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    16
    Hi all,


    What is the command to disable suexec in shell?(i can't access whm at this moment.)
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You need to rename:

    /usr/local/apache/bin/suexec

    to:

    /usr/local/apache/bin/suexec.disable

    then stop and restart apache:

    httpd stop
    httpd start
     
  3. SeñorAmor

    SeñorAmor Well-Known Member

    Joined:
    Dec 27, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    I tried doing that (since disabling suExec from WHM causes Internal Server Errors) and I got the following output:

    Warning: User directive in <VirtualHost> requires SUEXEC wrapper.
    Warning: Group directive in <VirtualHost> requires SUEXEC wrapper.

    Far as I can remember, before I updated to 9.4, I had suExec disabled. Now I can't disable it.

    Any ideas?
     
  4. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    if you can't disable Suexec within the WHM, you'll need to edit the httpd.conf file for each of the <VirtualHost> directives and comment out the User and Group setting foreach for the <VirtualHost> listed in the httpd.conf. Then restart apache. But if you enable suexec at a later date, make sure you uncomment them all otherwise apache will complain :)

    Mickalo
     
  5. SeñorAmor

    SeñorAmor Well-Known Member

    Joined:
    Dec 27, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Eh, it doesn't really bother me that it's on as much as my stupid pam_authentication stopped working.
     
Loading...

Share This Page