The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Complete Honesty

Discussion in 'General Discussion' started by StateofAffairs, Aug 3, 2006.

  1. StateofAffairs

    StateofAffairs Registered

    Joined:
    Aug 3, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I'm going to be 100% honest with this. I've been searching the net for about 3 or 4 hours now trying to find a tutorial or an article describing what to do and I've had no luck. CPanel is part of my package and I've done a very basic draft for my home page in Dream Waver. I've save the .html file to my directory using FTP but for the utter life of me, I can't get the .html file installed. After getting frustrated with that, I downloaded a template from the Template Express add-on in Fantastico but can't seem to get that working. I know all of this comes off as extremely noobish but that's pretty much because I'm running on zero experience with CPanel and Dreamweaver, I've only done very basic manual html. Thanks in advance for any help and I'm sorry if I might have overlooked the answers already here in the forums.


    Oh! I should include that I can't get in touch with my host administrator for questioning either.
     
  2. Messiah

    Messiah Member
    PartnerNOC

    Joined:
    Jul 5, 2006
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    You really didn't provide many details, so it's hard to say what the problem is specifically. The only guess I have is that you put the html file in your home directory, not in your document root.

    Say you have the domain blah.com setup on a cPanel server with the account blah. In that case, http://blah.com/ is going to open the file /home/blah/public_html/index.html. If you saved index.html as /home/blah/index.html, then there's no way you'll be able to open it with a web browser.

    Here are some more examples:
    http://blah.com/subfolder/test.php will open the file /home/blah/public_html/subfolder/test.php
    http://blah.com/huh.htm will open the file /home/blah/public_html/huh.htm

    Of course, permissions will have to be correct on the files as well, but if you're using FTP to stick them in your home directory, then they should be correct by default.
     
  3. StateofAffairs

    StateofAffairs Registered

    Joined:
    Aug 3, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Sorry, not sure what I should include. I had it saved as an index.html file but renamed the file. I had it installed in my index and then moved it into the public_html directory. For some reason, if you go to my site www.stateofaffairsmusic.com it doesn't even give me an error page, it just takes me to the search thing as if my site doesn't even exist. It's quite frustrating for a simple mind such as mine :D


    Oh! I forgot that all of the permissions are on.
     
  4. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Oddly (and I mean oddly oddly), http://www.stateofaffairsmusic.com/, for me, redirects to http://www.w3.org/Protocols/. That doesn't quite seem right!

    However, as Messiah said, you'll need to upload your index.html to your public_html directory. Your public_html directory is where http://www.stateofaffairsmusic.com/ should point and index.html should be loaded by default if no specific file is specified in the URL.

    If you have done this and things aren't working correctly, you should contact your host as they are best placed to investigate - in fact, they are the only people who can suitably investigate this for you.
     
  5. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    If you have a good host they should have provided you details on this with your welcome letter and had tutorials on their site to teach you some of this. All .htm, .html, .php files should be uploaded to your public_html folder. When you are setting up Dreamweaver sites you will want to set it up for FTP, www.yourdomain.com, public_html (the upload directory) and then your username/password. That is in the edit sites or create sites menu on the last page. You can click the test button at the bottom to make sure it connects.
     
  6. StateofAffairs

    StateofAffairs Registered

    Joined:
    Aug 3, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the tips, I'll go ahead and reconfigure my dreamweaver setup and make sure it points to public_html. It seems though that I had renamed the file as index.html and placed it there. I'm not sure why you get that when you go to the site, I'm completely dumb founded as that goes.
     
  7. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    I'm guessing you fixed it, as it pulls up now...
     
Loading...

Share This Page