Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Compress::Zlib object version 1.33 does not match $Compress::Zlib::VERSION 1.34.

Discussion in 'General Discussion' started by firexit, May 2, 2005.

  1. firexit

    firexit Active Member

    Joined:
    Nov 4, 2004
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    158
    Hello to all..
    I need somebody to help me here! im loosing it .. allready.

    when i upgrade to EDGE latest version from R164 - the CPANEL crashed! here is the output:


    service cpanel restart
    Stopping cPanel services: [ OK ]
    Stopping pop3 services: [ OK ]
    Stopping cPanel log services: [ OK ]
    Stopping cPanel Chat services: [FAILED]
    Stopping Melange Chat services: [FAILED]
    Stopping InterChange services: [FAILED]
    Stopping cPanel ssl services: [ OK ]

    Stopping mailman services: Shutting down Mailman's master qrunner

    Starting eximstats: [ OK ]
    Starting cPanel services: Compress::Zlib object version 1.33 does not match $Compress::Zlib::VERSION 1.34.
    [FAILED]
    Starting cPanel Log services: [ OK ]
    Starting pop3 services: [ OK ]
    Starting cPanel Chat services:
    Starting Melange Chat services:
    Starting cPanel ssl services: [ OK ]
    Starting mailman services: Starting Mailman's master qrunner.

    after reading more then 50 threads on this forums!

    i tried under /scripts/:

    ./updatenow --force
    ./sysup --force
    ./rhlupdate --force
    ./upcp --force
    ./perlinstaller --force Compress::Zlib

    /usr/local/cpanel/bin/checkperlmodules

    also tried:

    perl -MCPAN -e shell
    force install Compress::Zlib

    but nothing helped!!!!!
    im loosing it! users cant login to cpanel and i cant also!
    please help me
    10x.
    firexit
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Ultimately, you should be able to fix it by reinstalling perl using the package on http://layer1.cpanel.net and then running /scripts/rpmup repeatedly until it runs clean.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. firexit

    firexit Active Member

    Joined:
    Nov 4, 2004
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    158
    i fixed it - but not completly

    hi ...
    10x for the fast reply
    i ran it all .. also the perlinstaller

    what eventually helped in to downgrade to stable - run ./upcp and then updrade to edge again
    and run ./upcp --force

    but something wierd happends ... on tweak settings the option to use old pwd auth in mysql doesnt apear and im using : WHM 10.0.0 cPanel 10.2.0-E23
    RedHat 9 i686 - WHM X v3.1.0

    do u have any solution?
    do u know how i update it?
    tried to update the backend but diesnt help





    btw: all of this upgrade was bcz i wanted to use MYSQL 4.1.11 and i needed support for older pwds auth.


    10x
    firexit
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice