Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

ConfigServer Mail Queues

Discussion in 'E-mail Discussion' started by d-woo, May 10, 2007.

  1. d-woo

    d-woo Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    156
    I use the ConfigServer Mail Queues (great stuff).

    Recently, my /tmp directory got full so I moved my logwatch files to root and restarted exim.

    My mail is no longer being delivered and my mail queue has over 800 emails and growing.

    In WHM, when I go to an individual email and attempt to deliver it I get the following error

    Code:
    2007-05-10 09:46:45 1Hm8qM-00083s-OX == jim@jims_domain.com R=virtual_sa_user T=virtual_sa_userdelivery defer (-24): Transport filter process failed (127): unable to execute command
     
  2. bornonline

    bornonline Well-Known Member

    Joined:
    Nov 19, 2004
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Earth
  3. d-woo

    d-woo Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    156
    Thanks BornOnLine.

    I reinstalled the Perl modules.

    I emptied the /tmp/logwatch.Chb24687/maillog file (which was causing the /tmp folder to be 100% full) and rebooted the server.

    When I use CMQ in WHM and attempt to deliver a single email, I now get the following error:
    Code:
    LOG:: MAIN
      cwd=/usr/local/cpanel/whostmgr/docroot 4 args: exim -v -M 1Hjdpz-0002Ae-FO
    delivering 1Hjdpz-0002Ae-FO
    
    LOG: MAIN
      : virtual_sa_userdelivery transport output: An error was detected while 
    processing a file of BSMTP input.
    
    LOG: MAIN PANIC
    
      == [email]jim@jimsdomain.com[/email] R=virtual_sa_user T=virtual_sa_userdelivery defer (-24): 
    Transport filter process failed (127): unable to execute command
    

    Additionally, when I run

    root@server [~]# /etc/rc.d/init.d/exim restart

    I get:

    Code:
    Shutting down clamd:                                       [  OK  ]
    Shutting down exim:                                        [  OK  ]
    Shutting down antirelayd:                                  [  OK  ]
    Shutting down spamd:                                       [FAILED]
    Starting clamd:                                            [  OK  ]
    Starting exim-26:                                          [  OK  ]
    Starting exim:                                             [  OK  ]
    Starting exim-smtps:                                       [  OK  ]
    Starting antirelayd:                                       [  OK  ]
     
  4. d-woo

    d-woo Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    156
  5. tukaramg

    tukaramg Member

    Joined:
    Sep 22, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    Transport filter process failed (127): unable to execute command"

    Hello,

    Please try

    /scripts/fixspamassassinfailedupdate

    It will fix your problem...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice