Configuration of custom_begin_rbl issue

shenzy

Well-Known Member
Apr 27, 2008
86
33
68
Chile
cPanel Access Level
Root Administrator
Hello,
In my servers I have a configuration entered in the "custom_begin_rbl" section of the advanced exim configuration.
The problem is that every time I modify the exim configuration from the "basic editor", the "custom_begin_rbl" section in the advanced editor is unchecked. Therefore every time I make changes in the basic editor I must go to the advanced editor, then put the ticket in "custom_begin_rbl" and restart exim again. Does anyone know why this could be happening?
 

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,266
1,301
363
Houston
Hello @shenzy

This is checked when you want to add a new RBL - are the existing RBL's present? You can see custom RBL's by going to WHM>>Service Configuration>>Exim Configuration Manager ->RBLs

Thanks!
 

shenzy

Well-Known Member
Apr 27, 2008
86
33
68
Chile
cPanel Access Level
Root Administrator
Hello @cPanelLauren
Yes, I have a custom RBL added. I've tried it even on a new server, just configured. Every time I change something in the basic editor, I have to go to the advanced to activate the custom rbl and save the changes.
 

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,266
1,301
363
Houston
Hi @shenzy


Trying this on my server and I'm not seeing that behavior. Here are the steps I took:

  • I added a custom RBL by going to WHM>>Service Configuration>>Exim Configuration Manager -> Manage
  • Then I went back and enabled the newly added RBL and saved the configuration
  • I then modified some portion of the exim configuration through the basic editor and saved
  • Went back and checked to ensure my RBL was still enabled by going to the RBL's section of the basic editor and found that it was indeed still enabled.
Please let me know if I'm getting the replication steps incorrectly and what I would need to do to properly replicate this.