The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

configure exim need help

Discussion in 'E-mail Discussions' started by edzzone, Sep 22, 2012.

  1. edzzone

    edzzone Member

    Joined:
    Sep 22, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi I am new to setting up my mail system and learning. I have purchase vps+cpanel and configured somehow my mail server since it can send mail internally and use its dedicated IP every mail. My concern is how to configure exim so that I can use the smtp settings to run in my desktop mailer. It wont allow me and I cannot connect to my smtp server. any help is highly appreciated.
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    pretty straight forward

    user someuser@youdomain.com
    SMTP Host Address: mail.yourdomain.com (your ip address can be uses as well)
    outgoing Mail Server ---- My server requires authentication should be checked (optional)
    should be checked if you are only sending


    Note your ISP may block remote SMTP on port 25 in this case set up exim to listen on a different port
     
  3. pwhjenny

    pwhjenny Well-Known Member

    Joined:
    Aug 31, 2012
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    What desktop mailer you use? outlook?
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Of note, if your desktop mailer instead means some desktop mailing list script to send large quantities of email, then you'll probably need to add your IP for relaying. Here's a post on doing that:

    http://forums.cpanel.net/f43/add-ip-range-allowed-relay-hosts-268021.html#post1121531

    For that file (/etc/alwaysrelay), it will need the IP of your local system for that system to be allowed to relay emails through your server.
     
  5. edzzone

    edzzone Member

    Joined:
    Sep 22, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Yes I use Microsoft Outlook manual configuration using this simple smtp settings cpanel provided
    Mail Server Username: admin+mydomain.com
    Incoming Mail Server: mail.mydomain.com
    Supported Incoming Mail Protocols: POP3, POP3S (SSL/TLS), IMAP, IMAPS (SSL/TLS)
    Supported Outgoing Mail Protocols: SMTP, SMTPS (SSL/TLS)
    port 26
    ssl port 465

    when I check require logon using Secure Password Authentication + ssl port 465 and run test account settings it says failed logon to mailserver. but when uncheck + use port 26 and run test account settings again it will log me in but send a test email message failed and this is the error.
    Send test e-mail message: Cannot send the message. Verify the email address in your account properties. The server response:550 Access denied - Invalid HELO name (See RFC2821 4.1.1.1)

    done editing /etc/alwaysrelay and added my ISP IP address.
     
  6. edzzone

    edzzone Member

    Joined:
    Sep 22, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    by the way I have not done any major editing on exim execept for a tuts here to set mail send on its dedicated IP. I feel like there is something need to be edited on exim.conf so that it can accept mail routed or relayed properly. Any suggestion? all mails are working internally though in webmail.
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You might not even have port 26 enabled as the alternate port. Go to WHM > Service Manager and check "exim on another port" field. Check both options next to it and change it to 587 and then save the area.

    At that point, use 587 for the exim port.

    Also, use admin@mydomain.com for your username (and ensure that it uses the full email address rather than just admin). For the incoming and outgoing servers, use mydomain.com rather than mail.mydomain.com

    At that point, if it still isn't working, submit a ticket if you have root level access to the machine using WHM > Support Center > Contact cPanel.
     
Loading...

Share This Page