Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Configure Exim to Send Email From a Subaccount

Discussion in 'E-mail Discussion' started by Mustafa Chapal, Nov 1, 2018.

  1. Mustafa Chapal

    Mustafa Chapal Registered

    Joined:
    Nov 1, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    Hi,

    I am using Mandrill for specific domains to send email and I have configured Section: AUTH, Section: PREROUTERS and Section: TRANSPORTSTART.

    Everything is working fine except if I want to send email using the Mandrill subaccount. For that I have added the following line to Section: TRANSPORTSTART but specifically sending email using the subaccount is not working.

    headers_add = "X-MC-Subaccount: $original_local_part@$original_domain\n"

    I would appreciate the help.

    Thanks
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,272
    Likes Received:
    2,154
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @Mustafa Chapal,

    Can you provide some more information about what in-specific isn't working when attempting to send out the email? Also, can you post the output from /var/log/exim_mainlog for the affected message, in addition to the specific entries you are using to customize Exim in each configuration section?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Mustafa Chapal

    Mustafa Chapal Registered

    Joined:
    Nov 1, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    Hi Michael,

    I want to add/set a header to emails with the following tag in such a way that it brings in the sender domain or sender account username.

    headers_add = "X-MC-Subaccount: domainname" OR headers_add = "X-MC-Subaccount: accountusername"


    To achieve the above I tried setting the following line but then the emails stopped sending.

    headers_add = "X-MC-Subaccount: $original_local_part@$original_domain\n"


    Following is the exim log output:

    Code:
    2018-11-04 04:51:00 SMTP connection from [172.93.xxx.xxx]:56086 (TCP/IP connection count = 2)
    
    2018-11-04 04:51:04 SMTP connection from [::1]:51790 (TCP/IP connection count = 3)
    
    2018-11-04 04:51:05 1gJ5h3-0007Ww-EH H=(example.net) [::1]:51790 Warning: Message has been scanned: no virus or other harmful content was found
    
    2018-11-04 04:51:05 1gJ5h3-0007Ww-EH <= someusr@example.com H=(example.net) [::1]:51790 P=esmtpa A=dovecot_login:someusr@example.com S=566 id=7dbbdde998feefdc2eaeb36a94894ff1@example.com T="test6" for someusr@gmail.com
    
    2018-11-04 04:51:05 SMTP connection from (example.net) [::1]:51790 closed by QUIT
    
    2018-11-04 04:51:05 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1gJ5h3-0007Ww-EH
    
    2018-11-04 04:51:06 1gJ5h3-0007Ww-EH [54.255.xxx.x] SSL verify error: certificate name mismatch: DN="/C=US/ST=Georgia/L=Atlanta/O=blahblahblah/OU=Product Dev/CN=mandrillapp.com" H="smtp.ap-southeast-1.mandrillapp.com"
    
    2018-11-04 04:51:06 1gJ5h3-0007Ww-EH => someusr@gmail.com R=smart_route T=auth_relay H=smtp.ap-southeast-1.mandrillapp.com [54.255.xxx.x] X=TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256 CV=no A=auth_login C="250 2.0.0 Ok: queued as 109912420F1"
    
    2018-11-04 04:51:06 1gJ5h3-0007Ww-EH Completed
    
    2018-11-04 04:51:10 TLS error on connection from [172.93.xxx.xxx]:56086 (SSL_accept): error:00000000:lib(0):func(0):reason(0)
    
    2018-11-04 04:51:10 SMTP connection from [172.93.xxx.xxx]:56657 (TCP/IP connection count = 2)
    
    2018-11-04 04:51:12 SMTP connection from [37.49.xxx.xx]:62826 lost D=15s
    
    2018-11-04 04:51:16 SMTP connection from [37.49.xxx.xx]:54917 (TCP/IP connection count = 2)
    
    2018-11-04 04:51:16 no host name found for IP address 37.49.xxx.xx
    
    2018-11-04 04:51:21 TLS error on connection from [172.93.xxx.xxx]:56657 (SSL_accept): error:00000000:lib(0):func(0):reason(0)
    
    2018-11-04 04:51:21 SMTP connection from [172.93.xxx.xxx]:57163 (TCP/IP connection count = 2)
    
    2018-11-04 04:51:24 SMTP connection from [23.111.xxx.xx]:50638 (TCP/IP connection count = 3)
    
    2018-11-04 04:51:31 SMTP connection from [37.49.xxx.xx]:54917 lost D=15s
    
    2018-11-04 04:51:32 TLS error on connection from [172.93.xxx.xxx]:57163 (SSL_accept): error:00000000:lib(0):func(0):reason(0)
    
    2018-11-04 04:51:32 SMTP connection from [172.93.xxx.xxx]:57642 (TCP/IP connection count = 2)
    
    2018-11-04 04:51:39 SMTP connection from [127.0.0.1]:40130 (TCP/IP connection count = 3)
    
    2018-11-04 04:51:41 SMTP connection from [127.0.0.1]:40130 closed by QUIT
    
    2018-11-04 04:51:42 TLS error on connection from [172.93.xxx.xxx]:57642 (SSL_accept): error:00000000:lib(0):func(0):reason(0)
    
    2018-11-04 04:51:43 SMTP connection from [172.93.xxx.xxx]:58140 (TCP/IP connection count = 2)
    
    2018-11-04 04:51:44 SMTP connection from s4005.pingdom.com (s4005) [23.111.xxx.xx]:50638 closed by QUIT
    
    2018-11-04 04:51:53 TLS error on connection from [172.93.xxx.xxx]:58140 (SSL_accept): error:00000000:lib(0):func(0):reason(0)
    
    2018-11-04 04:51:53 SMTP connection from [172.93.xxx.xxx]:58629 (TCP/IP connection count = 1)
    
    Thanks
     
    #3 Mustafa Chapal, Nov 3, 2018
    Last edited by a moderator: Nov 3, 2018
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,272
    Likes Received:
    2,154
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @Mustafa Chapal,

    You may also want to review /var/log/exim_paniclog to see if any additional output appears when testing the custom Exim configuration. Keep in mind this level of customization is unsupported. If you're unable to determine the cause of the issue, I recommend reaching out to Mandrill for direct assistance. If they are unable to help, you can find a list of system administration service providers at:

    System Administration Services | cPanel Forums

    The Exim User's mailing list is an additional resource to use:

    Exim-users Info Page

    Let us know what you find.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice