Configure FTP Directory Access

matthewtbaker

Registered
Feb 15, 2013
3
0
1
cPanel Access Level
Root Administrator
Hi,

I have recently configured my new WHM 'VPS optimised 3' and am trying to figure out how to specify which directory an accounts ftp connection defaults to.

Currently when an account user ftp's into their root they are automatically taken to the 'public_html' directory and are unable to go a level up to their home directory. However when browsing using cPanel File Manager they can access the /home directory.

I am using Pure-FTPD.

Question: How do I configure the default directory to be /home instead of /home/public_html and to allow users go a level up from /public_html to /home?

Thank you!
Matt
 

matthewtbaker

Registered
Feb 15, 2013
3
0
1
cPanel Access Level
Root Administrator
Thanks Infopro, good questions!

Is this happening on all accounts?
I thought it was, but it turns out it is only affecting additional FTP accounts added through cPanel. The account holder is able to view the entire folder structure within their root, however any other FTP account holders added cannot go above 'public_html'.

Are we talking about the cPanel user account or an addon FTP account?
I guess this would be an addon FTP user account as the users are being created under the 'Add FTP Account' option through cPanel.

What FTP client is being used?
FileZilla 3.5.3


I'm starting to think that perhaps additional FTP accounts cannot view the root, which would be a pain. Is that the case?

Many thanks.

- - - Updated - - -

I continued my hunt and found http://support.hostgator.com/articles/how-to-create-an-ftp-account-in-cpanel. This site instructed to insert a single '/' into the directory field and the root would then be enabled.

Thank you for helping me out. Your initial questions got me thinking down the right track.
 

Infopro

Well-Known Member
May 20, 2003
17,113
507
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
Is that the case?
Yes. Addon FTP users are restricted to the directory you provide them with.

IIRC, the way around that was, instead of leaving the default path that's auto filled on addon FTP account creation, add a dot instead.

So on that addon FTP account page where you see: Directory: /home/username/ __________

Add one of these: .

Please give this a go and post back if you don't mind. :)