The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Configure Mail Client Shows Wrong Server Info

Discussion in 'E-mail Discussions' started by HowardE, Mar 28, 2016.

  1. HowardE

    HowardE Member

    Joined:
    Aug 8, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Florida
    cPanel Access Level:
    Root Administrator
    When using the webmail application, and the "configure mail client" option, the SSL/TLS information doesn't actually use the registered SSL server for the service.

    Under Home > Service Configuration > Manage Service SSL Certificates, I do have the SSL server for the mail properly listed as server.mydomain.com
    -----------------

    Not sure if this is related, but under

    Home » Server Configuration > Tweak Settings

    I have the default options checked for "DOMAINS" and I searched for "proxy" and all of those are on default too.

    --------------------------------

    The ISSUE:

    When using the

    Configure Mail Client option in the webmail for any of the domains under my WHM

    for example: www.domain1.com


    The settings shown in the box on the Configure Mail Client

    Secure SSL/TLS Settings
    (Recommended)
    Username: info@domain1.com
    Password: Use the email account’s password.
    Incoming Server: domain1.com
    • IMAP Port: 993
    • POP3 Port: 995
    Outgoing Server: domain1.com
    • SMTP Port: 465
    -------------------

    However, the shared SSL server for the email is server.mydomain.com
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Is a SSL certificate installed for the individual domain name associated with the account with the Mail SNI functionality enabled?

    Thank you.
     
  3. HowardE

    HowardE Member

    Joined:
    Aug 8, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Florida
    cPanel Access Level:
    Root Administrator
    So, for other domains that have an SSL, but aren't using their SSL for the mail service, I have to disable the Mail SNI function for those domain names, keeping the SNI Service only active for the primary mail server host name. Right?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Yes, that is correct. You can disable SNI for mail services for a specific domain name via:

    "WHM Home » SSL/TLS » Manage SSL Hosts"

    Thank you.
     
Loading...

Share This Page