Configure MX entries for shared IP and reverse DNS check?

Miguel G

Well-Known Member
Jun 4, 2015
86
0
6
Spain
cPanel Access Level
Root Administrator
Twitter
I have a WHM 68 server hosting several hosting accounts. All MX entries in the accounts are configured this way by default:
Code:
domain.com. 14400 IN A 111.111.111.111
domain.com. 14400 IN MX 0 domain.com
mail 14400 IN CNAME domain.com.
domain.com 14400 IN TXT "v=spf1 +a +mx +ip4:111.111.111.111 ~all"
Well, I am getting from a spam checker the following message reporting no reverse DNS entry is available:
Code:
SMTP error from remote mail server after RCPT TO:<[email protected]>:
550 5.7.0 Your server IP address [111.111.111.111] is missing a reverse DNS entry. See Check IP Reverse DNS | Spam Auditor Blog for more information. Protection provided by MagicSpam 2.0.16-1 http://www.magicspam.com
I don´t really understand why I am getting this message since I have one separate domain with an external mail server I configured that have a similar setup:
Code:
mydomain.com. 14400 IN A 222.222.222.222
mydomain.com. 14400 IN MX 0 mail.mydomain.com
mail 14400 IN A 222.222.222.222
mydomain.com 14400 IN TXT "v=spf1 +a +mx +ip4:222.222.222.222 ~all"
in fact, my reverse entry for 222.222.222.222 is not mail.mydomain.com but zimbra.mydomain.com and emails from this server are not bouncing.

So what am I doing wrong?
 
Last edited by a moderator:

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
806
156
168
New Jersey
cPanel Access Level
DataCenter Provider
The DNS zone in cPanel doesn't control the PTR record you usually have to ask your host to set that for you so basically just make sure that

111.111.111.111 resolves to your.serverhostname.com

and the PTR record for your.serverhostname.com resolves to 111.111.111.111

111.111.111.111 doesn't necessarily have to be the primary IP on the server which would be your hostname so you would just check the mail headers when you send out an email, on the receiving end that is, and look for which IP its actually coming from and ensure that IP forward and reverse resolves to the same hostname.
 

Miguel G

Well-Known Member
Jun 4, 2015
86
0
6
Spain
cPanel Access Level
Root Administrator
Twitter
@Jcats I don´t quite get you. The 111.111.111.111 resolves to cpanel.mydomain.com and my cpanel.mydomain.com resolves to 111.111.111.111.

Mail has been working for 3 years. I´m just finding this problem with one particular domain and their antispam rules.

In the mail headers in the bounced message they are getting my IP address as stated above.
 

Miguel G

Well-Known Member
Jun 4, 2015
86
0
6
Spain
cPanel Access Level
Root Administrator
Twitter
@Jcats I don´t quite get you. The 111.111.111.111 resolves to cpanel.mydomain.com and my cpanel.mydomain.com resolves to 111.111.111.111.

Mail has been working for 3 years. I´m just finding this problem with one particular domain and their antispam.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,262
313
Houston
Hi @Miguel G

It could be a number of things changing on the recipient side causing your rDNS to not be recognized. Do you get a valid rDNS when you query the sending IP and the IP of domain sending mail?

I find it's easiest to get a good idea by running the following via CLI:

Code:
host <domainIP>
Thanks!
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,262
313
Houston
hi @Miguel G

It actually doesn't matter where you run it, as long as you do so from a Linux command line prompt. All it does is look for an associated PTR record for the IP address. You would want to run it at least for the mail sending IP (if that's the mail server).

Thanks!
 

Miguel G

Well-Known Member
Jun 4, 2015
86
0
6
Spain
cPanel Access Level
Root Administrator
Twitter
Well, then, if you read carefully my previous messages in this thread is quite clear that forward and reverse DNS entries are pointing to the right IP and hostname.

I didn´t get any call from the receiver sysadmin, I will ask them to run that command on their mail server.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,262
313
Houston
Your error:

Code:
SMTP error from remote mail server after RCPT TO:<[email protected]>:
550 5.7.0 Your server IP address [111.111.111.111] is missing a reverse DNS entry. See Check IP Reverse DNS | Spam Auditor Blog for more information. Protection provided by MagicSpam 2.0.16-1 http://www.magicspam.com
Very clearly indicates that the antispam software they're using is rejecting your mail for a lack of an rDNS entry, if it exists as you indicate and is not misconfigured (which can also cause this error) then I would suggest contacting them directly as they're not seeing the rDNS.

Thanks!
 

Miguel G

Well-Known Member
Jun 4, 2015
86
0
6
Spain
cPanel Access Level
Root Administrator
Twitter
Well, if you read my response to @Jcats :

I don´t quite get you. The 111.111.111.111 resolves to cpanel.mydomain.com and my cpanel.mydomain.com resolves to 111.111.111.111.
And of course I run the host command reporting correctly what I say from my cpanel server:

Code:
#host 111.111.111.111
111.111.111.111.in-addr.arpa domain name pointer cpanel1.mydomain.com.
 

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
806
156
168
New Jersey
cPanel Access Level
DataCenter Provider
  • Like
Reactions: cPanelLauren

rpvw

Well-Known Member
Jul 18, 2013
1,101
459
113
UK
cPanel Access Level
Root Administrator
Several of my customers have experienced difficulties getting mail through to destinations that use MagicSpam.

I contacted the destination webhost that deployed the MagicSpam service and explained what had occurred, I never did hear anything back but, as if by magic, the emails all suddenly started to be accepted.

I would agree that your only option is to contact the recipient, and try and get them to persuade whoever is responsible for the MagicSpam service to help.
 
  • Like
Reactions: cPanelLauren