The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Configure smart host with authentication

Discussion in 'E-mail Discussions' started by dodul, Dec 11, 2013.

  1. dodul

    dodul Registered

    Joined:
    Dec 11, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I am trying to configure Smart Host in my WHM web server. My smarthost provider requires SMTP authentication. I am using WHM 11.4

    Thanks In advanced!

    K

    - - - Updated - - -

    Can anyone give me some clues how to do it?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The following option is available under the "Mail" tab in "WHM Home » Service Configuration » Exim Configuration Manager":

    "Smarthost support"

    You can enter the smart host server name directly with this option.

    Thank you.
     
  3. dodul

    dodul Registered

    Joined:
    Dec 11, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    Thanks a lot for your reply. I have already done that. And I have checked my exim can connect with the smarthost successfully. However, the issue is my smarthost requires SMTP authentication. And I cant figure how to provide SMTP authentication information to my exim. After adding manual route through Exim basic editor. I can see the below code has been added to my exim.conf


    Code:
    boxtrapper_verify_dkim_lookuphost:
        driver = manualroute
        route_list = * outmail.profilter.co.uk::587
        domains = ! +local_domains
        condition = "${if eq {$h_X-Boxtrapper:}{}{0}{1}}"
        #ignore verisign to prevent waste of bandwidth
        ignore_target_hosts = +loopback : 64.94.110.0/24
        require_files = "+/var/cpanel/domain_keys/private/${sender_address_domain}" 
        headers_add = "${perl{mailtrapheaders}}"
        transport = dkim_remote_smtp
    
    #
    # Lookup host router for remote smtp and ignores verisign site finder 'service' and uses domain keys
    #
    
    
    dkim_lookuphost:
        driver = manualroute
        route_list = * outmail.profilter.co.uk::587
        domains = ! +local_domains
        #ignore verisign to prevent waste of bandwidth
        ignore_target_hosts = +loopback : 64.94.110.0/24
        require_files = "+/var/cpanel/domain_keys/private/${sender_address_domain}" 
        headers_add = "${perl{mailtrapheaders}}"
        transport = dkim_remote_smtp
    
    #
    # Lookup host router for remote smtp and ignores verisign site finder 'service'
    # This matches lookup exactly except we look for X-Boxtrapper: so we can determine
    # what is a boxtrapper generated message in the log.  Note: there is nothing to 
    # prevent X-Boxtrapper from being added to non-boxtrapper messages so this is for
    # logging reasons only
    #
    
    
    boxtrapper_verify_lookuphost:
        driver = manualroute
        route_list = * outmail.profilter.co.uk::587
        domains = ! +local_domains
        condition = "${if eq {$h_X-Boxtrapper:}{}{0}{1}}"
        #ignore verisign to prevent waste of bandwidth
        ignore_target_hosts = +loopback : 64.94.110.0/24
        headers_add = "${perl{mailtrapheaders}}"
        transport = remote_smtp
    
    #
    # Lookup host router for remote smtp and ignores verisign site finder 'service'
    #
    
    
    lookuphost:
        driver = manualroute
        route_list = * outmail.profilter.co.uk::587
        domains = ! +local_domains
        #ignore verisign to prevent waste of bandwidth
        ignore_target_hosts = +loopback : 64.94.110.0/24
        headers_add = "${perl{mailtrapheaders}}"
        transport = remote_smtp
    
    
    # This router routes to remote hosts over SMTP by explicit IP address,
    # given as a "domain literal" in the form [nnn.nnn.nnn.nnn]. The RFCs
    # require this facility, which is why it is enabled by default in Exim.
    # If you want to lock it out, set forbid_domain_literals in the main
    # configuration section above.
    
    Now, can some one guide me how to add the SMTP authentication info aswell ?


    Thanks in advanced!

    K
     
    #3 dodul, Dec 11, 2013
    Last edited by a moderator: Dec 12, 2013
  4. dodul

    dodul Registered

    Joined:
    Dec 11, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Is there anyone who can help ?
     
Loading...

Share This Page