The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

'./configure --with-apache=/home/cpeasyapache/src/apache_1.3.42' failed with exit cod

Discussion in 'EasyApache' started by pratapsingh, Nov 12, 2010.

  1. pratapsingh

    pratapsingh Active Member

    Joined:
    Mar 20, 2009
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Hello ,

    I tried running easyapache but I am getting the following error ,


    -- Begin opt 'Dav' --
    -- Begin step 'Configure' --
    !! './configure --with-apache=/home/cpeasyapache/src/apache_1.3.42' failed with exit code '-1' (IE: command not found) !!

    What is this error means I am not sure , I just wanted to enable the pdo extension .

    Any help would be appreciated.
    Thank you
     
  2. pratapsingh

    pratapsingh Active Member

    Joined:
    Mar 20, 2009
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Re: './configure --with-apache=/home/cpeasyapache/src/apache_1.3.42' failed with exit

    current installed Apache version on the server is 1.3.41 , I am not sure while running why it is taking apache_1.3.42 .. I hope this the reason it is failing.

    Do any one have any idea about this how to change this to 1.3.41 as I do not want to change the version of apache.

    Thanks
     
  3. pratapsingh

    pratapsingh Active Member

    Joined:
    Mar 20, 2009
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Re: './configure --with-apache=/home/cpeasyapache/src/apache_1.3.42' failed with exit

    here is the output of the command
    /scripts/easyapache --version

    =========================
    Easy::Apache v3.2.0 Build 5247

    [cpanel]
    11.28.33-CURRENT_50494


    [apache]
    Server version: Apache/1.3.41 (Unix)
    Server built: Jun 18 2009 11:43:43
    Cpanel::Easy::Apache v3.2.0 rev4730

    =========================

    But it is still taking apache_1.3.42 , I do not know what is wrong with easyapache.
     
  4. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Re: './configure --with-apache=/home/cpeasyapache/src/apache_1.3.42' failed with exit

    You last built Apache using EasyApache in June of 2009, or almost a year and a half ago, according to your /scripts/easyapache --version output. In that time, the version of Apache 1.3 that EasyApache builds has been updated from 1.3.41 to 1.3.42. This is normal, and nothing is wrong with EasyApache. EasyApache is updated to build newer minor versions of the major versions, and 1.3.41 to 1.3.42 is a minor version change.

    What is the output above this?

    Code:
    !! './configure --with-apache=/home/cpeasyapache/src/apache_1.3.42' failed with exit code '-1' (IE: command not found) !!
    The EasyApache logs are stored in /usr/local/cpanel/logs/easy/apache, and they will contain the complete output from the build.

    I recommend submitting a ticket so that we may log in and investigate directly and make sure that EasyApache builds successfully for you.
     
  5. turncoat

    turncoat Registered

    Joined:
    Mar 23, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    DataCenter Provider
    Re: './configure --with-apache=/home/cpeasyapache/src/apache_1.3.42' failed

    Sorry for bringing this up, but it can help someone... I had this problem when my /home was on partition mounted with noexec flag... So mount -o remount,exec /home fixed it...
     
Loading...

Share This Page