The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Configured PHP version ea-php70 does not have a CGI binary installed

Discussion in 'CloudLinux' started by Milance, Jul 13, 2017.

  1. Milance

    Milance Member

    Joined:
    Apr 6, 2013
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Configured PHP version ea-php70 does not have a CGI binary installed, using default PHP version
    Default PHP version ea-php56 does not have a CGI binary installed, exiting
    php_cli unable to execute php :-1: (2) :No such file or directory:
    when attempting to run ()

    I receive this message every 5 minutes on email.

    Please help
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
  3. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    788
    Likes Received:
    6
    Trophy Points:
    168
    This started happening today. We haven't made any changes. User's cron jobs now fail with the following error....

    Default PHP version ea-php56 does not have a CGI binary installed, exiting
    php_cli unable to execute php :-1: (2) :No such file or directory:
    when attempting to run ()

    Everything was fine until today.

    Edit, or maybe 2 days ago...

    php -v
    ea-php-cli Copyright 2017 cPanel, Inc.
    PHP 5.6.31 (cli) (built: Jul 11 2017 16:59:27)
    Copyright (c) 1997-2016 The PHP Group

    I presume this was updated automatically.
     
  4. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    166
    Same problem since last night:

    Output from command /usr/bin/php -q /home/wom/public_html/google_sitemap_xml.php
    Configured PHP version php does not have a CGI binary installed, using default PHP version
     
  5. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    166
    and here:
    Output from command /usr/local/bin/php -q /home/wom/public_html/google_sitemap_xml.php
    Configured PHP version php does not have a CLI binary installed, using default PHP Version

    # php -v
    ea-php-cli Copyright 2017 cPanel, Inc.
    PHP 5.6.31 (cli) (built: Jul 11 2017 17:00:57)
    Copyright (c) 1997-2016 The PHP Group
     
  6. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    788
    Likes Received:
    6
    Trophy Points:
    168
    I noticed this in another thread...

    Should I find php-cli and php-cgi symlinks in /usr/bin because they are not there.

    On our EA3 based servers in /usr/bin I can see php-cli and php-cgi symlinks. php-cli points to /usr/local/bin/php and php-cgi points to /usr/bin/php.

    On the EA4 server there are none. I presume it's more complicated due to the different versions? I've not used EA4 much yet. I don't have any knowledge on the way this is set up

    All the binaries are present in /opt/cpanel/ea-php56/root/usr/bin

    Different results here...

    # php -v
    ea-php-cli Copyright 2017 cPanel, Inc.
    PHP 5.6.31 (cli) (built: Jul 11 2017 16:59:27)

    # /usr/bin/php -v
    ea-php-cli Copyright 2017 cPanel, Inc.
    PHP 5.6.31 (cgi-fcgi) (built: Jul 11 2017 16:59:31)
     
  7. Douglas Soares

    Douglas Soares Registered

    Joined:
    Jul 14, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Website Owner
    I'm getting something similar, this started today after I updated WHM.

    Code:
    Configured PHP version php does not have a CGI binary installed, using default PHP version
    This is the command used:

    Code:
    php -q /home/soaresen/public_html/integra/avisoCobranca.php sn
     
  8. NEMESISbyDesign

    Joined:
    Nov 17, 2007
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    53
    cPanel Access Level:
    DataCenter Provider
    I am receiving this as well

    "Configured PHP version php does not have a CGI binary installed, using default PHP version"

    This is the only result that comes up in Google when you search for it.

    This is fairly annoying as I have a cron that runs every 5 mins so I am constantly reminded of this issue...

    Anyone have any input on how to resolve this?
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello Everyone!

    It looks this error message could stem from a few separate issues. Please review the following potential issues and their solutions:

    1. Internal case EA-6542 is open to address an issue where commented PHP MIME types in .htaccess files can cause PHP version detection to break. Here's an example of such an entry in a .htaccess file:

    Code:
    #AddType application/x-httpd-phpXX .php
    I'll monitor this case and update this thread with more information on it's status as it becomes available. In the meantime, the workaround is to manually remove the commented entry from the .htaccess file.

    2. Internal case EA-6543 is open to address an issue where the PHP-CLI logic that checks the .htaccess file in the current working directory for PHP version declarations will attempt use MIME types that are unrelated to PHP, causing it to revert to the default PHP version after returning an error. Here's an example of such an entry in a .htaccess file:

    Code:
    AddType application/x-httpd-somethingelse .none
    AddType application/x-httpd-ea-php56 .php
    I'll monitor this case and update this thread with the outcome. The workaround for this case is to ensure a cPanel-recogized PHP MIME type is first MIME entry in the .htaccess file.

    3. If this is a CloudLinux system, check to ensure you are not using cPanel EA4 RPMs instead of the CloudLinux EA4 RPMs. Here's a command you can use to check this:

    Code:
    rpm -qa|grep ea-|grep cpanel
    If the YUM repos are properly configured on the CloudLinux server, then the output should resemble this:

    Code:
    # rpm -qa|grep ea-|grep cpanel
    ea-cpanel-tools-1.0-15.el6.cloudlinux.x86_64
    ea-profiles-cpanel-1.0-28.el6.cloudlinux.x86_64
    ea-libcurl-7.53.1-2.2.2.cpanel.x86_64
    If you see numerous EA4 RPMS ending with ".cpanel" instead of ".cloudlinux", then you will need to rerun the CloudLinux EA4 conversion script documented at the following URL:

    CloudLinux Documentation

    Thank you.
     
  10. Douglas Soares

    Douglas Soares Registered

    Joined:
    Jul 14, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Website Owner
    My htaccess file content:

    Code:
    # php -- BEGIN cPanel-generated handler, do not edit
    # Set the “ea-php70” package as the default “PHP” programming language.
    <IfModule mime_module>
      AddType application/x-httpd-php .php .php7 .phtml
    </IfModule>
    # php -- END cPanel-generated handler, do not edit
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Did you check to confirm no other .htaccess files exist in the account's public_html directory, or the subdirectory where the PHP file is located? Also, could you confirm if you are using CloudLinux, and if so, if you reviewed the third potential issue in my last response?

    Thanks!
     
  12. Douglas Soares

    Douglas Soares Registered

    Joined:
    Jul 14, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Website Owner
    I can confirm there is no other .htaccess file and I'm not using CloudLinux, I'm using CENTOS 6.9 x86_64.
     
  13. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Could you open a support ticket using the link in my signature so we can take a closer look?

    Thank you.
     
  14. Douglas Soares

    Douglas Soares Registered

    Joined:
    Jul 14, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Website Owner
    I will open it up on monday ok? It's past time to go home now haha, thanks for helping!
     
  15. WietseD

    WietseD Member

    Joined:
    Mar 29, 2017
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    netherlands
    cPanel Access Level:
    Root Administrator
    Hello all,

    Is there an eta when this issue will be resolved? It seems that php-wrapper is not working correctly for different versions of php.
    We are having the same issue.

    Thank you.
     
    Ram Freedman likes this.
  16. Ram Freedman

    Ram Freedman Registered

    Joined:
    Jul 18, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Israel
    cPanel Access Level:
    Website Owner
    Hi - same problem here... All of my cron commands are not working.
    I'm getting this error in the email:

    Configured PHP version ea-php70 does not have a CGI binary installed, using default PHP version
    Default PHP version ea-php56 does not have a CGI binary installed, exiting
    php_cli unable to execute php :-1: (2) :No such file or directory:
    when attempting to run ()

    Can you please help?
     
  17. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
  18. QuentinC

    QuentinC Member

    Joined:
    Jan 10, 2013
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    DataCenter Provider
    Same issue today but we don't have an overrided .htaccess and all rpm are CloudLinux:

    [root@cPserver~]# rpm -qa|grep ea-|grep cpanel
    ea-cpanel-tools-1.0-17.el7.cloudlinux.x86_64
    ea-profiles-cpanel-1.0-30.el7.cloudlinux.1.x86_64
    [root@cPserver~]

    Can you have a check ASAP ?
     
  19. QuentinC

    QuentinC Member

    Joined:
    Jan 10, 2013
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    DataCenter Provider
    Hello,

    Please perform the following command:

    yum update cagefs

    CageFS updated

    This should help.
    =========
    Code:
    Updated:
    cagefs.x86_64 0:6.0-50.el7.cloudlinux
    
    Dependency Updated:
    cagefs-safebin.x86_64 0:6.0-50.el7.cloudlinux
    
    Complete!
    [root@cPanelserver ~]# su cPuser
    [cPuser@cPanelserver root]$ php -v
    ea-php-cli Copyright 2017 cPanel, Inc.
    PHP 7.0.21 (cli) (built: Jul 11 2017 12:45:23) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.1.0 (), Copyright (c) 2002-2017, by ionCube Ltd.
    with Zend OPcache v7.0.21, Copyright (c) 1999-2017, by Zend Technologies 
    ===> It's Works !
     
    cPanelMichael likes this.
  20. ethix

    ethix Well-Known Member

    Joined:
    Dec 21, 2004
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Australia
    It did not work for me unfortunately :/
     
Loading...

Share This Page