The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Configuring Local Part Subaddressing

Discussion in 'E-mail Discussions' started by cyberstrider, Aug 27, 2008.

  1. cyberstrider

    cyberstrider Member

    Joined:
    Aug 27, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Newbie here so just wanted to confirm something before I try it.. do not wish to break a live service. :)

    Using WHM 11.23.2 cPanel 11.23.6-R26866 on CENTOS Enterprise 5.2 i686

    I'm looking at adding local-part suffix/subaddressing into our Exim config, via the 'Advanced Editor'

    I have not used the Advanced editor before and if I add the necessary code for the subaddressing, which box shall I add this in, and if I get it wrong, how easy it is to remove it? I am looking at adding + i and . for local part suffixing.. anyone here done any of this - are there any examples of the necessary code that anyone can share? :) (Yes, I have read the EXIM config documentation, just wanted to ensure I was doing things right within WHM)

    I am presuming that anything I add into the editable boxes in Advanced Editor will not over-write the rest of the exim config file?
     
  2. cyberstrider

    cyberstrider Member

    Joined:
    Aug 27, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Anyone?

    Someone must have done this... :)

    -DB
     
  3. norelidd

    norelidd Well-Known Member

    Joined:
    Jan 15, 2007
    Messages:
    173
    Likes Received:
    1
    Trophy Points:
    18
  4. cyberstrider

    cyberstrider Member

    Joined:
    Aug 27, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    So.. no one has done this via the Advanced Editor in cpanel?

    Does this mean I should manually edit the exim.conf file? However does this not get overwritten by cpanel and I would have to keep an eye on the conf file and re-edit everytime it is re-wwritten?

    That would be a pain with multiple cpanel servers... what do others here do?

    -DB
     
  5. norelidd

    norelidd Well-Known Member

    Joined:
    Jan 15, 2007
    Messages:
    173
    Likes Received:
    1
    Trophy Points:
    18
    You can vote for the bug in bugzilla and maybe the devs will pay more attention to it.
     
  6. paulkoan

    paulkoan Well-Known Member

    Joined:
    Nov 24, 2006
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Yes vote for the bug.

    However, the change to exim.conf looks pretty straightforward, but the question still remains about what happens with a cpanel update?

    Is there a way to get the

    Code:
      local_part_suffix = +*
      local_part_suffix_optional
    
    code to survive?

    Cheers,

    Paul
     
  7. blargman

    blargman Well-Known Member

    Joined:
    Sep 11, 2007
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    /etc/eximupdisable to disable exim updates and make sure you have backups I suppose. I'm interested in setting this up. Have you done it? can you post me a how to or anything?
     
  8. paulkoan

    paulkoan Well-Known Member

    Joined:
    Nov 24, 2006
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    I tried it and it didn't work - the emails just ended up at the default account.

    If you follow the link above it will take you to the bug submission and details of how to set it up.

    The short version is add the two lines above to localuser: and userforward: in exim.conf - but like I said, this didn't work for me.
     
  9. paulkoan

    paulkoan Well-Known Member

    Joined:
    Nov 24, 2006
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    It didn't work, but it *should* work, unless the router that is being used isn't the userforward: or localuser: router.

    Has anyone managed to get this working?
     
Loading...

Share This Page