The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Confirmation Emails rejected?

Discussion in 'E-mail Discussions' started by PortraitArtist, Aug 28, 2007.

  1. PortraitArtist

    PortraitArtist Registered

    Joined:
    May 13, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi Cpanel Gurus,
    I am a store owner happens to manage our site.
    I am not sure my question is belongs to here.
    Our shopping cart sends out confirmation emails automatically.
    Sometimes those emails are rejected by our customer's email servers.
    Here is part of the returned email:
    "Mail sent by user nobody being discarded due to sender restrictions in WHM->Tweak Settings"
    I am not familiar with email servers and delivery mode, but I am guessing that those emails should be send from "somebody".
    Where should I try make changes?
    1; On CPanel?
    2; On my mail program? (Hosted by Stormwire)
    3; On my shopping cart program? (Zencart)
    Please help me figure out a solution for this problem.
    Thank you, Istvan Parragh
    Website: www.vodmochka.com
    PS. We use SpamAssasin and Spam folders, if that make any difference.
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    If your server is to block user nobody from sending email, you must ensure your scripts are not running as system user nobody.

    There are two solutions:
    • The better solution is to enable SuExec and PhpPSuExec on your servers so all scripts run as the user on which those scripts reside rather than as user nobody.
    • The simpler but unrecommended solution is to disable that setting in tweak settings.

    To enable suexec, go to WHM -> Service Configuration -> Enable/Disable SuExec

    To enable phpsuexec, go to WHM -> Software -> Apache Update and recompile being sure to select PhpSuExec support.
     
Loading...

Share This Page