The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

conflicts between attempted installs of MySQL55 / MYSQ56

Discussion in 'Database Discussions' started by efree, Jul 7, 2014.

  1. efree

    efree Registered

    Joined:
    Oct 14, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    After a attempt at upgrading mysql through whm > software > upgrade mysql
    I got 500 error from webserver when loading a website that runs mysql

    I ran fixes from this thread
    http://forums.cpanel.net/f354/mysql-upgrade-whm-mysql-5-1-5-5-a-364302.html

    But i get package conflicts:

    Code:
    root@bigfella [~]# /scripts/update_local_rpm_versions –edit target_settings.MySQL55 uninstalled
    root@bigfella [~]# /usr/local/cpanel/scripts/check_cpanel_rpms –fix
    [20140708.005235]
    [20140708.005235]   Problems were detected with cPanel-provided files which are RPM controlled.
    [20140708.005235]   If you did not make these changes intentionally, you can correct them by running:
    [20140708.005235]
    [20140708.005235]   > /usr/local/cpanel/scripts/check_cpanel_rpms --fix
    [20140708.005235]   The following RPMs are missing from your system:
    [20140708.005235]   MySQL55-client-5.5.36-1.cp1136
    [20140708.005235]   MySQL55-devel-5.5.36-1.cp1136
    [20140708.005235]   MySQL55-server-5.5.36-1.cp1136
    [20140708.005235]   MySQL55-shared-5.5.36-1.cp1136
    [20140708.005235]   MySQL55-test-5.5.36-1.cp1136
    [20140708.005235]   MySQL56-client-5.6.16-4.cp1142
    [20140708.005235]   MySQL56-devel-5.6.16-4.cp1142
    [20140708.005235]   MySQL56-server-5.6.16-4.cp1142
    [20140708.005235]   MySQL56-shared-5.6.16-4.cp1142
    [20140708.005235]   MySQL56-test-5.6.16-4.cp1142
    Do you want to repair these RPMs?(y/n):
    y
    [20140708.005314]   Removing 0 broken rpms:
    [20140708.005314]   rpm: no packages given for erase
    [20140708.005316]   Downloading http://httpupdate.cpanel.net/RPM/11.36/centos/6/x86_64/rpm.md5
    [20140708.005316]   Downloading http://httpupdate.cpanel.net/RPM/11.42/centos/6/x86_64/rpm.md5
    [20140708.005316]   Downloading http://httpupdate.cpanel.net/RPM/11.36/centos/6/x86_64/MySQL55-client-5.5.36-1.cp1136.x86_64.rpm
    [20140708.005322]   Downloading http://httpupdate.cpanel.net/RPM/11.36/centos/6/x86_64/MySQL55-test-5.5.36-1.cp1136.x86_64.rpm
    [20140708.005329]   Downloading http://httpupdate.cpanel.net/RPM/11.42/centos/6/x86_64/MySQL56-shared-5.6.16-4.cp1142.x86_64.rpm
    [20140708.005330]   Downloading http://httpupdate.cpanel.net/RPM/11.36/centos/6/x86_64/MySQL55-devel-5.5.36-1.cp1136.x86_64.rpm
    [20140708.005333]   Downloading http://httpupdate.cpanel.net/RPM/11.42/centos/6/x86_64/MySQL56-devel-5.6.16-4.cp1142.x86_64.rpm
    [20140708.005334]   Downloading http://httpupdate.cpanel.net/RPM/11.36/centos/6/x86_64/MySQL55-shared-5.5.36-1.cp1136.x86_64.rpm
    [20140708.005336]   Downloading http://httpupdate.cpanel.net/RPM/11.36/centos/6/x86_64/MySQL55-server-5.5.36-1.cp1136.x86_64.rpm
    [20140708.005350]   Downloading http://httpupdate.cpanel.net/RPM/11.42/centos/6/x86_64/MySQL56-client-5.6.16-4.cp1142.x86_64.rpm
    [20140708.005358]   Downloading http://httpupdate.cpanel.net/RPM/11.42/centos/6/x86_64/MySQL56-test-5.6.16-4.cp1142.x86_64.rpm
    [20140708.005418]   Downloading http://httpupdate.cpanel.net/RPM/11.42/centos/6/x86_64/MySQL56-server-5.6.16-4.cp1142.x86_64.rpm
    [20140708.005437]   Hooks system enabled
    [20140708.005437]   Checking for and running RPM::Versions 'pre' hooks for any RPMs about to be installed
    warn [check_cpanel_rpms] program "/scripts/premysqlup" is not executable
    [20140708.005437]   All required 'pre' hooks have been run
    [20140708.005438]   No RPMS need to be uninstalled
    [20140708.005438]   Installing new rpms: MySQL55-client-5.5.36-1.cp1136.x86_64.rpm MySQL55-test-5.5.36-1.cp1136.x86_64.rpm MySQL56-shared-5.6.16-4.cp1142.x86_64.rpm MySQL55-devel-5.5.36-1.cp1136.x86_64.rpm MySQL56-devel-5.6.16-4.cp1142.x86_64.rpm MySQL55-shared-5.5.36-1.cp1136.x86_64.rpm MySQL55-server-5.5.36-1.cp1136.x86_64.rpm MySQL56-client-5.6.16-4.cp1142.x86_64.rpm MySQL56-test-5.6.16-4.cp1142.x86_64.rpm MySQL56-server-5.6.16-4.cp1142.x86_64.rpm
    [20140708.005439]   Preparing packages for installation...
    [20140708.005440]       file /usr/bin/mysql conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    [20140708.005440]       file /usr/bin/mysql_waitpid conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    [20140708.005440]       file /usr/bin/mysqlaccess conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    [20140708.005440]       file /usr/bin/mysqladmin conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    [20140708.005440]       file /usr/bin/mysqlbinlog conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    [20140708.005440]       file /usr/bin/mysqlcheck conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    [20140708.005440]       file /usr/bin/mysqldump conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    [20140708.005440]       file /usr/bin/mysqlimport conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    [20140708.005440]       file /usr/bin/mysqlshow conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    [20140708.005440]       file /usr/bin/mysqlslap conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    [20140708.005440]       file /usr/share/man/man1/msql2mysql.1.gz conflicts between attempted installs of MySQL56-client-5.6.16-4.cp1142.x86_64 and MySQL55-client-5.5.36-1.cp1136.x86_64
    
    <<CUT OUT LARGE SIMILAR OUTPUT>>
    
    [20140708.005440]       file /usr/include/mysql/plugin_ftparser.h conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440]       file /usr/include/mysql/sql_common.h conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440]       file /usr/include/mysql/sql_state.h conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440]       file /usr/include/mysql/sslopt-case.h conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440]       file /usr/include/mysql/sslopt-longopts.h conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440]       file /usr/include/mysql/sslopt-vars.h conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440]       file /usr/include/mysql/typelib.h conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440]       file /usr/lib64/mysql/libmysqlclient.a conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440]       file /usr/lib64/mysql/libmysqlservices.a conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440]       file /usr/share/man/man1/comp_err.1.gz conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440]       file /usr/share/man/man1/mysql_config.1.gz conflicts between attempted installs of MySQL55-devel-5.5.36-1.cp1136.x86_64 and MySQL56-devel-5.6.16-4.cp1142.x86_64
    [20140708.005440] W Error Code: 10
    [20140708.005440]   Prelinking is disabled.
    [20140708.005440]   Checking for and running RPM::Versions 'post' hooks for any RPMs just installed
    warn [check_cpanel_rpms] program "/scripts/postmysqlinstall" is not executable
    warn [check_cpanel_rpms] program "/scripts/postmysqlup" is not executable
    [20140708.005440]   All required 'post' hooks have been run
    root@bigfella [~]#
    
    root@bigfella [~]# /scripts/update_local_rpm_versions –edit target_settings.MySQL55 uninstalled
    root@bigfella [~]# /usr/local/cpanel/scripts/check_cpanel_rpms –fix
    [20140708.005652]
    [20140708.005652]   Problems were detected with cPanel-provided files which are RPM controlled.
    [20140708.005652]   If you did not make these changes intentionally, you can correct them by running:
    [20140708.005652]
    [20140708.005652]   > /usr/local/cpanel/scripts/check_cpanel_rpms --fix
    [20140708.005652]   The following RPMs are missing from your system:
    [20140708.005652]   MySQL55-client-5.5.36-1.cp1136
    [20140708.005652]   MySQL55-devel-5.5.36-1.cp1136
    [20140708.005652]   MySQL55-server-5.5.36-1.cp1136
    [20140708.005652]   MySQL55-shared-5.5.36-1.cp1136
    [20140708.005652]   MySQL55-test-5.5.36-1.cp1136
    [20140708.005652]   MySQL56-client-5.6.16-4.cp1142
    [20140708.005652]   MySQL56-devel-5.6.16-4.cp1142
    [20140708.005652]   MySQL56-server-5.6.16-4.cp1142
    [20140708.005652]   MySQL56-shared-5.6.16-4.cp1142
    [20140708.005652]   MySQL56-test-5.6.16-4.cp1142
    
    root@bigfella [~]# mysql
    -bash: mysql: command not found
    root@bigfella [~]# cat /var/cpanel/cpanel.config | grep mysql-v
    mysql-version=5.6
    



    Tried fix from this website:
    /http://rivenlinux.info/cpanel-mysql-upgrade-conflicts-between-attempted-installs-version-error/
    No joy
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please feel free to open a support ticket using the link in my signature if you have yet to resolve this issue. You can post the ticket number here and we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page