The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

congratulations to Cpanel on imortal exim (sarcasm)

Discussion in 'General Discussion' started by denisdekat09, May 26, 2004.

  1. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    Someone was abusing my email, no matter what I did, no matter how much I turned exim off, and turned it off under services and teh fscking thing keeps running :) It is imortal, unstoppable!!!

    That is just great, now how do I turn it off if I really want it off? I tried chanin setting, restartin cpanel, stoping exim with killall exim and service exim stop and it is still running... Any ideas
     
  2. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Fix the relay would be your best answer. You could start by doing chkservd -2345 exim off. This would stop the restart of it.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I would suspect that you've probably got someone running a script on-server. If so, stopping exim will have no effect because you can still run it directly and it will deliver the email.

    To stop that you would need to rename the binary file out of the way:

    mv /usr/sbin/exim /usr/sbin/exim_gone
     
  4. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    Not sure what exactly it was, but blocking an IP from a client seemed to stop the abusive use...

    I had tried desperately to set exim off and to stop it but it wold only start. Once I blocked that IP, the server was ok. Also, I do have the SMTP tweak turned on...

    Man, that was really annoying however, why can't you just service exim stop and that is it?

    "You could start by doing chkservd -2345 exim off" But I had set exim off under the service manager in the WHM, why would it restart it and I had restarted cpanel also.... mmmm Maybe that would have worked...

    I am not sure you are right about the on-server scriptie, I could not find one for the life of me. I have yet to find out from that client what is going on, but it had something to do with http://eplus2.com/ and tons of bounced messages..... GRrrrrrr :mad: I don't like the looks of it at all...

    Thanks for the tips :) next time I think renaming the exim binary will help. I guess I could have put a line of junk in the conf file and forced it to crash come to think of it, but I tend not to think that way ;)
     
  5. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    disable the nobody mail sender and check. This should stop the mails from being send from a script (will work only if you don't have phpsuexec compiled)
     
  6. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    yeah, but I had phpsuexec, and it really does not look like he was scripting it, I have been up and down his site....

    I need to talk to the guy to find out what he was doing :)

    thanks to all for the great ideas and tips :)
     
Loading...

Share This Page